Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 29 Jul 2014, 18:54
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Eclipse crashes when auto-completion used
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [8 Posts]  
Author Message
PuppyZox

Joined: 28 May 2014
Posts: 12

PostPosted: Thu 29 May 2014, 13:44    Post subject:  Eclipse crashes when auto-completion used  

Hello,
I just install puppy latest version Slacko 5.7
But when I launch eclipse, when I do auto-completion eclipse crash without error message. What can I do to fix it ?
Thanks.
Back to top
View user's profile Send private message 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 10942
Location: Arizona USA

PostPosted: Thu 29 May 2014, 15:44    Post subject:  

It appears that you posted this same question in the French section of the forum. If anyone there has an answer, please update this English thread with it for the benefit of English-speaking forum members who may be trying to help you. Thank you.
Back to top
View user's profile Send private message 
PuppyZox

Joined: 28 May 2014
Posts: 12

PostPosted: Tue 03 Jun 2014, 05:06    Post subject:  

I have some news, I succed to find the error log generated by Eclipse.
I don't have it currently on my computer, but i will edit my post when I have.

This error appear : "Failed to write core dumps" or something like that.
I've try to start with more memory, to add something like "-unlimit -c unlimited", to change GTK Theme to Classic, and to change the Web Brower form default to Firefox. It's what is saying into other forum which concern this problem, but nothing works.

Then, when I go to Window -> Preferences -> Web Brower, Eclipse close immediatly with the same error.

That's appear on Puppy Linux only; I don't have this bug on Debian or Windows XP.
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7785
Location: qld

PostPosted: Tue 03 Jun 2014, 07:08    Post subject:  

This might be a RAM problem. How much RAM do you have? Adding/increasing swap may help.

For the record, I have no such problem with netbeans but I do have 4GB RAM.

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
PuppyZox

Joined: 28 May 2014
Posts: 12

PostPosted: Tue 03 Jun 2014, 09:37    Post subject:  

I have only 512MB RAM on my computer.
But It's work fine on Debian :/ (Often freeze but never crash)
Back to top
View user's profile Send private message 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 10942
Location: Arizona USA

PostPosted: Tue 03 Jun 2014, 10:04    Post subject:  

512 MB of RAM should be enough for just about anything to run in Puppy.
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7785
Location: qld

PostPosted: Tue 03 Jun 2014, 17:02    Post subject:  

I think 512 isn't enough to run puppy + jdk + eclipse.

Puppy running in RAM uses a fair bit and it won't leave much room for jdk + eclipse which are both substantial. There is no mention of a swap partition/file?

Also, were there any error messages when you started eclipse from the commandline?

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
PuppyZox

Joined: 28 May 2014
Posts: 12

PostPosted: Wed 04 Jun 2014, 02:53    Post subject:  

I don't have any error when I start Eclipse.
I print the memory consumption, on start Eclipse need ~70MB on Puppy, ~170MB on Debian.
And I don't have any crashes with Debian however I have the same available RAM :S
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [8 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0553s ][ Queries: 11 (0.0103s) ][ GZIP on ]