Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 02 Oct 2014, 09:03
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
CUPS error: localhost:631/Admin == ERROR 404
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 2 Posts_count   Goto page: 1, 2 Next
Author Message
boof

Joined: 26 Sep 2012
Posts: 185

PostPosted: Thu 29 May 2014, 22:01    Post_subject:  CUPS error: localhost:631/Admin == ERROR 404
Sub_title: HP 1510 printer installation
 

Puppy_slacko_5.7

having entered the main CUPS menu
I select <Add Printers and Classes> and get the above error for the address.

Printer is plugged in, and turned on.
firewall was running before printer turned on.
was re-run after printer turned on.
Have not tested printer data cable, but will. It shouldn't matter, from past experience.
hplip is downloaded.
?
Back to top
View user's profile Send_private_message 
Semme

Joined: 07 Aug 2011
Posts: 3939
Location: World_Hub

PostPosted: Thu 29 May 2014, 22:34    Post_subject:  

If cups is running, read here.
Back to top
View user's profile Send_private_message 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 11083
Location: Arizona USA

PostPosted: Thu 29 May 2014, 22:40    Post_subject:  

Boof, I'm trying to help you out by changing your subject line. The idea is, more people might read your post if the subject line tells them something about what's in it.
Back to top
View user's profile Send_private_message 
boof

Joined: 26 Sep 2012
Posts: 185

PostPosted: Thu 29 May 2014, 22:42    Post_subject:  

CUPS is running,
I've accidentally loaded CUPS 1.5.x onto my system, but I'm only supposed to have 1.4.x.
perhaps this is the problem, as it might have entered with the hplip???? How can I revert pls?

btw thx for editing subject.
Back to top
View user's profile Send_private_message 
mikeb


Joined: 23 Nov 2006
Posts: 8257

PostPosted: Fri 30 May 2014, 07:32    Post_subject:  

Hmm when I tried slackwares cups 1.5 it was horrendously broken and could never have worked but I am sure its better now....perhaps geeks don't print Very Happy

No removal option in the package manager?

You will see the files in /initrd/pup_rw for a hacky way to remove but if you are not certain what you are doing then don't.

Otherwise perhaps a fresh save file might be a better idea...sometimes faster in the long run

Mike
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9162
Location: Stratford, Ontario

PostPosted: Fri 30 May 2014, 10:11    Post_subject:  

boof wrote:
as it might have entered with the hplip????

Installing a printer driver package would not break the CUPS web interface.

The CUPS system in Puppy was built specifically for Puppy. You should not try to upgrade it.
Back to top
View user's profile Send_private_message 
boof

Joined: 26 Sep 2012
Posts: 185

PostPosted: Fri 30 May 2014, 23:28    Post_subject:
Sub_title: Diagnosed-not fixed.
 

I've done a complete 3x re-install from a fresh download of puppy_slacko-5.7*.exe from mediafire.com as of 10.00am {gmt+8} 31/5/2014.

Sorry to say it's got cups-1.5.4 installed by default, according to ppm.

I won't risk the MB to compare the .iso and see what it has. I suspect it's the same.

I have managed to nut out the my HP PSC 1510 needs a <socket://127.0.0.1> connection with the hpijs driver from hplip.

Thanks
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9162
Location: Stratford, Ontario

PostPosted: Sat 31 May 2014, 00:17    Post_subject:  

I have slacko-5.7-NO-pae.iso which definitely contains CUPS 1.4.8 and it works correctly with the hplip_print-3.14.4.pet.

I cannot comment on what you are downloading from mediafire.
Back to top
View user's profile Send_private_message 
boof

Joined: 26 Sep 2012
Posts: 185

PostPosted: Sat 31 May 2014, 00:28    Post_subject:  

file source pls.

NB Might be something to do with having to work under windows????
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9162
Location: Stratford, Ontario

PostPosted: Sat 31 May 2014, 00:56    Post_subject:  

The usual repo.
Back to top
View user's profile Send_private_message 
boof

Joined: 26 Sep 2012
Posts: 185

PostPosted: Sun 01 Jun 2014, 13:39    Post_subject:  

"the usual repo" means nothing to me. I'm a noob. you HAVE to be very exact or I won't be able to follow you. I've re downloaded the iso from the aarnet mirror, and it's contaminated too. I've spent days on this now. I fear we have the makings of a problem......
Back to top
View user's profile Send_private_message 
mikeb


Joined: 23 Nov 2006
Posts: 8257

PostPosted: Sun 01 Jun 2014, 13:44    Post_subject:  

I stopped using mediafire as I kept getting corrupted downloads...that may not be helping matters

mike
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9162
Location: Stratford, Ontario

PostPosted: Sun 01 Jun 2014, 14:31    Post_subject:  

boof wrote:
"the usual repo" means nothing to me.

That's a link. Click on it.
Back to top
View user's profile Send_private_message 
SFR


Joined: 26 Oct 2011
Posts: 1072

PostPosted: Sun 01 Jun 2014, 14:56    Post_subject:  

boof wrote:
Sorry to say it's got cups-1.5.4 installed by default, according to ppm.

Use this instead of PPM, it's more straightforward and clean method to determine what version is preinstalled:
Code:
grep -i '^cups-' /root/.packages/woof-installed-packages

You should get:
Quote:
# grep -i '^cups-' /root/.packages/woof-installed-packages
cups-1.4.8-w5c|cups|1.4.8-w5c||BuildingBlock|7192K||cups-1.4.8-w5c.pet||common unix printing system, note uses kernel module usblp for usb printers|puppy|wary5||
#

Greetings!

_________________
[O]bdurate [R]ules [D]estroy [E]nthusiastic [R]ebels => [C]reative [H]umans [A]lways [O]pen [S]ource
Omnia mea mecum porto.
Back to top
View user's profile Send_private_message 
boof

Joined: 26 Sep 2012
Posts: 185

PostPosted: Sun 01 Jun 2014, 15:13    Post_subject:  

Solved, thx.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 2 Posts_count   Goto page: 1, 2 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0812s ][ Queries: 11 (0.0138s) ][ GZIP on ]