Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 23 Aug 2014, 11:22
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
slacko-6.0 beta 2
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 41 [613 Posts]   Goto page: 1, 2, 3, ..., 39, 40, 41 Next
Author Message
01micko


Joined: 11 Oct 2008
Posts: 7794
Location: qld

PostPosted: Tue 17 Jun 2014, 17:18    Post subject:  slacko-6.0 beta 2
Subject description: big changes that I hope you hardly notice
 

Slacko 6.0 β

5.9.3 k 3.4.94

iso (~168 M) and delta from 5.9.2>>5.9.3 (+checksums)

Up at Ibiblio and NLUUG

For the devx use the one for 5.9.2. There are no header changes

kernel_source sfs is here + checksum (=direct link, my site, may be slow).

This release is 4G (non PAE)

Thanks to everybody who tested and gave feedback for alpha and beta1. I reckon this is as good a beta as can be released, above alpha quality.

Quote:

Changelog

beta2
pmusic-4.3.6 - zigbert
mhwaveedit-1.4.23 - rebuilt - SFR
desk_icons_blue_moon_Slacko-1 - ttuuxxx

bugfixes
--------
init - sfs causing kernel panic on reboot - MHHP - commit 213e2d8
drop test for aufs in various scrpts - SFR - commit 40d485f
restored broadcom firmware


beta1
pavrecord-0.9.4 - upgrade - mcewanw, SFR
precord-8.1.5 - upgrade - mcewanw, SFR
pup-advert-blocker-3b - upgrade - OscarTalks
+pdesktop-0.1 - new - zigbert
-gtk-chtheme - removed
acpid-busibox-3 - shinobar
updates_mgr-0.11 - me
mtpaint-3.44.73 - upgrade - wjaguar
mhwaveedit-1.4.23 - built by SFR
gifsicle-1.83 - built by SFR
abiword-3.0.0 - rebuilt
gparted-0.19.0 - upgrade
sylpheed-3.4.2 - upgrade
squashfs-tools-4.3 - upgrade
+musl-1.1.2 - new - > devx
linux-3.4.94 - patched f2fs,aufs, ext2,3,4 + added jfs,btrfs,xfs as builtins

bugfixes
--------
intrd.gz/init - mavrothal
cups - perms - jamesbond, shinobar
MultipleSoundCardWizard - bugfix - Geoffrey, kirk
mksquashfs - symlink - shinobar
shutdownconfig - fix fail in CLI - shinobar
kernel_headers - update - old 5.7 version was in devx
firmware - cut down, saves ~7MB in iso
blkid - fix woof template - musher0
wireless_tools - missing libiw - SFR, davids45
pcre - symlink libpcre.so.0 - SFR
rc.update - attempt to fix icon mess when load sfs/update system


alpha
pmusic-4.3.5 zigbert
pburn-4.3.5 zigbert
psync-2.10 npeirce, tasmod
sfs_load-2.0.8 shinobar
tas-1.6 SFR
network_roxapp-0.8-1 shinobar, kirk
abiword-3.0.0
ffmpeg-2.2.3
xvidcore-14.06.17-git
libvpx-14.06.17-git
curlftpfs-0.9.2
+gpicview-2.4
-viewnior
firefox-24.6.0-ESR
kernel-3.4.93-4G

update to slackware-14.1 packages
new woof infrastructure

TODO
update sylpheed -done
update mtpaint -done
update mksquashfs -done
plus much more


There are some big changes here which as an end user you should hardly notice.

These include:
  • update to slackware-14.1 package base
  • complete change of how puppy boots. We are now using kernel modules and firmware in a zdrive. There are no kernel modules in initrd.gz. This is how it's done in FatDog. Thanks jamesbond and kirk.
  • save folder thanks to the collective efforts of gyro, shinobar, mavrothal and others. At shutdown you will see a new option to 'save to directory'. This replaces 'save to partition'.


This thing boots for me on 5 machines I tried and connects no issue, including 2 old clunkers. Saving works. There is a possible bug with saving from CLI interface - please test fixed (still test if you can).

There will likely be bugs. Perhaps many. I do not want to add more features, rather squash the bugs. If you want features, compile them and I'll consider them for the repo.

Bugs you may encounter not already mentioned are kernel bugs. If slacko booted fine for you before and doesn't now I need to know. It may be a kernel or firmware issue. Ditto if you can't connect.

Please check for user space bugs (mounting, applications, general running etc).

There is only old slacko stuffs in the slacko repo for now. I will build stuffs as time permits. Builders of programs wanted.

Why is this so big?
Firmware. I may trim that substantially -done.

Why change the kernel method if it wasn't broken?
Because it was cumbersome - duplication of modules, moving modules from initrd to root, difficulty in changing kernels. Now, you can change a kernel by building one with kernel-kit. Simply build a kernel with the "FD=1" option in the build.conf, make sure your .config supports aufs and many other modules as builtins (that is, WHATEVER_CONFIG=y not =m), add some firmware (manually for now, to do: automatic) and replace the z drive with your kernel-modules.sfs-$MY-KERNEL, renaming it to whatever the z drive is now, and replacing vmlinuz with vmlinus-$MY-KERNEL and reboot. That's it. More later on this feature.



The reason I went 4G only is that I might bring slacko64 up to release standard. I will drop PAE if that is the case. I do not want a flame war about this. Any single post moaning about this either way will be requested to be deleted. Save it for a different thread. (Ping Flash). This decision is subject to change for reasons known to me only.
Have fun! Smile

Last edited by 01micko on Sun 22 Jun 2014, 23:21; edited 11 times in total
Back to top
View user's profile Send private message Visit poster's website 
01micko


Joined: 11 Oct 2008
Posts: 7794
Location: qld

PostPosted: Tue 17 Jun 2014, 17:19    Post subject:  

Why is this here?

For updates.

-

1. Just pushed changes to woof-CE > 0cdbfa8 commit

2. aarf (remember him?) has kindly provided a torent.

_________________
Woof Mailing List | keep the faith Cool |

Last edited by 01micko on Tue 17 Jun 2014, 20:25; edited 2 times in total
Back to top
View user's profile Send private message Visit poster's website 
James C


Joined: 26 Mar 2009
Posts: 5711
Location: Kentucky

PostPosted: Tue 17 Jun 2014, 17:24    Post subject:  

Downloading .......and preparing to have fun. Smile
Back to top
View user's profile Send private message 
SFR


Joined: 26 Oct 2011
Posts: 1054

PostPosted: Tue 17 Jun 2014, 20:10    Post subject:  

Quick test on Acer AO 722 - boots fine from USB stick, everything looks fine, connects though WiFi just fine.
Created heavy-encrypted savefile (I haven't had ext? formatted USB stick at hand, only vfat) - ok.
TAS seems to play nice with newer ffmpeg.

More tomorrow. Cool

Greetings!

_________________
[O]bdurate [R]ules [D]estroy [E]nthusiastic [R]ebels => [C]reative [H]umans [A]lways [O]pen [S]ource
Omnia mea mecum porto.
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9042
Location: Stratford, Ontario

PostPosted: Tue 17 Jun 2014, 21:49    Post subject:  

The most recent version of Legacy GRUB Config 2013 is here.

The version in Slacko 591 has a completely different user interface. How did this happen? Has this modified version become the standard in woof-ce?

What testing did this version get to ensure that nothing broke?

The Help button in the modified version links to the forum page of the official version. So who is taking responsibility for providing user support for the modified version?
Back to top
View user's profile Send private message 
sszindian


Joined: 24 Apr 2010
Posts: 601
Location: Pennsylvania U.S.

PostPosted: Tue 17 Jun 2014, 22:53    Post subject: prinjting doesnt work with USB  

'Confirmed as per rcrsn51'

Used drivers from rcrsn51 thread (3-14's) and also drivers from the PPM (there's only a one-for-all package for the USB HP hplip) Results...

'NO PRINTER FOUND' however, a quick check of xsane and the scanner does work just fine!

Looks like the same problem 'Tahr' has and maybe that's the reason that build doesn't print either?


>>>---Indian------>

_________________
Cloud Computing For Every Puppy (a .pet)
http://murga-linux.com/puppy/viewtopic.php?t=69192
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9042
Location: Stratford, Ontario

PostPosted: Tue 17 Jun 2014, 23:03    Post subject:  

As with the Tahr situation, this has nothing to do with driver packages and everything to do with USB hardware detection on some machines.

In the Tahr thread, I made several suggestions for work-arounds. Did you try them? What were the results?
Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 2079
Location: Ontario Canada

PostPosted: Tue 17 Jun 2014, 23:19    Post subject: slacko-6.0 alpha  

Manual frugal install to an 8gb sdhc card.

video-info-glx 1.5.1 Tue 17 Jun 2014 on Slacko Puppy 5.9.1 Linux 3.4.93 i686
0.0 VGA compatible controller: nVidia Corporation Device 1082 (rev a1)
oem: NVIDIA
product: GF110 Board - 12630002 Chip Rev
X Server: Xorg Driver: nvidia
X.Org version: 1.14.3
dimensions: 3840x1080 pixels (1204x343 millimeters)
depth of root window: 24 planes
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTX 560 Ti/PCIe/SSE2
OpenGL core profile version string: 4.3.0 NVIDIA 340.17
Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz

I lost the mouse temporarily when running xorgwizard and choosing the
proprietary Nvidia driver but ctrl-alt-backspace and then startx got
to the desktop and the mouse works again.

Will test PPM next.

Edit:
I updated PPM and downloaded kdegames, everything downloaded and
installed in PPM but nothing showed up in the menu, trying to run
kpatience in gexec gave an error.
I also ran fixmenus and restarted X but nothing added to the Fun
section of the menu.
It appears that some files were downloaded.
EDIT:
Used getflash to install the flashplugin and started up firefox, it crashed immediately, deleted flashplugin and firefox is working again.
error.jpg
 Description   
 Filesize   12.05 KB
 Viewed   5366 Time(s)

error.jpg

usr-bin.jpg
 Description   
 Filesize   24.81 KB
 Viewed   5382 Time(s)

usr-bin.jpg

Screenshot.jpg
 Description   
 Filesize   17.77 KB
 Viewed   5384 Time(s)

Screenshot.jpg

Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 5711
Location: Kentucky

PostPosted: Wed 18 Jun 2014, 00:09    Post subject:  

Live pfix=ram on my new main Linux box. Other than needing to use SNS for internet connection all basics good ootb.

Code:
# report-video
VIDEO REPORT: Slacko Puppy, version 5.9.1

Chip description:
VGA compatible controller: nVidia Corporation C68 [GeForce 7050 PV / nForce 630a] (rev a2)

Requested by /etc/X11/xorg.conf:
  Resolution (widthxheight, in pixels): 1024x768x16
  Depth (bits, or planes):              24
  Modules requested to be loaded:       dbe

Probing Xorg startup log file (/var/log/Xorg.0.log):
  Driver loaded (and currently in use): nouveau
  Loaded modules: dbe dri2 exa extmod fb glx kbd mouse shadowfb

Actual rendering on monitor:
  Resolution:  1440x900 pixels (380x238 millimeters)
  Depth:       24 planes

...the above also recorded in /tmp/report-video



Code:
# glxgears
Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
4212 frames in 5.0 seconds = 842.209 FPS
4273 frames in 5.0 seconds = 854.464 FPS
4339 frames in 5.0 seconds = 867.683 FPS
4282 frames in 5.0 seconds = 856.339 FPS


Code:
-Computer-
Processor      : 2x AMD Athlon(tm) 64 X2 Dual Core Processor 3800+
Memory      : 3112MB (203MB used)
Machine Type      : Physical machine
Operating System      : Slacko Puppy - 5.9.1
User Name      : root (root)
Date/Time      : Tue 17 Jun 2014 11:07:37 PM CDT
-Display-
Resolution      : 1440x900 pixels
OpenGL Renderer      : Gallium 0.4 on NV67
X11 Vendor      : The X.Org Foundation
-Audio Devices-
Audio Adapter      : HDA-Intel - HDA NVidia


Did a manual frugal install........lets see if it'll boot. Smile

EDIT:
Manually installed Flash 11.2r202..... no problems.
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 5711
Location: Kentucky

PostPosted: Wed 18 Jun 2014, 00:26    Post subject:  

James C wrote:

Did a manual frugal install........lets see if it'll boot. :.


Same result as latest Tahr builds...... immediate kernel panic.

Shutting down from the live run it did make a save folder successfully ...... just cannot boot from an install.
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 5711
Location: Kentucky

PostPosted: Wed 18 Jun 2014, 00:36    Post subject:  

Same stuff...different box. Everything working on initial boot, including internet.


Code:
# report-video
VIDEO REPORT: Slacko Puppy, version 5.9.1

Chip description:
VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02)

Requested by /etc/X11/xorg.conf:
  Resolution (widthxheight, in pixels): 1024x768
  Depth (bits, or planes):              24
  Modules requested to be loaded:       dbe

Probing Xorg startup log file (/var/log/Xorg.0.log):
  Driver loaded (and currently in use): intel
  Loaded modules: dbe dri2 extmod fb glx kbd mouse

Actual rendering on monitor:
  Resolution:  1024x768 pixels (270x203 millimeters)
  Depth:       24 planes

...the above also recorded in /tmp/report-video



Code:
# glxgears
Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
372 frames in 5.0 seconds = 74.246 FPS
376 frames in 5.0 seconds = 75.153 FPS
376 frames in 5.0 seconds = 75.143 FPS
376 frames in 5.0 seconds = 75.144 FPS
376 frames in 5.0 seconds = 75.143 FPS
376 frames in 5.0 seconds = 75.144 FPS


Code:
-Computer-
Processor      : 2x Intel(R) Pentium(R) 4 CPU 3.00GHz
Memory      : 2064MB (192MB used)
Machine Type      : Physical machine
Operating System      : Slacko Puppy - 5.9.1
User Name      : root (root)
Date/Time      : Tue 17 Jun 2014 11:35:31 PM CDT
-Display-
Resolution      : 1024x768 pixels
OpenGL Renderer      : Mesa DRI Intel(R) 865G x86/MMX/SSE2
X11 Vendor      : The X.Org Foundation
-Audio Devices-
Audio Adapter      : ICH4 - Intel ICH5


Trying another frugal install. Smile
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7794
Location: qld

PostPosted: Wed 18 Jun 2014, 00:39    Post subject:  

James

Run this and post the tarball running pfix=ram.

Code:
tar -cjf logs-$HOSTNAME.tar.bz2 /initrd/tmp


Anyone else with fugal-install/panic/save issues please do the same.

Thanks

_________________
Woof Mailing List | keep the faith Cool |

Last edited by 01micko on Wed 18 Jun 2014, 01:10; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
James C


Joined: 26 Mar 2009
Posts: 5711
Location: Kentucky

PostPosted: Wed 18 Jun 2014, 00:45    Post subject:  

As expected (since it did the same with Tahr) frugal install w/ save folder boots fine on the Intel box. GetFlash fine...Firefox still working.
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 5711
Location: Kentucky

PostPosted: Wed 18 Jun 2014, 00:46    Post subject:  

01micko wrote:
James

Run this and post the tarball running pfix=ram.

Code:
tar -cjf logs-$HOSTNAME.tar.bz2 /initrd/tmp


Anyone else with save issues please do the same.

Thanks


Code:
# tar -cjf logs-$HOSTNAME.tar.bz2 /initrd/tmp
tar: Removing leading `/' from member names
#
logs-puppypc31908.tar.bz2
Description 
bz2

 Download 
Filename  logs-puppypc31908.tar.bz2 
Filesize  1.31 KB 
Downloaded  39 Time(s) 
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 5711
Location: Kentucky

PostPosted: Wed 18 Jun 2014, 00:51    Post subject:  

01micko wrote:

Anyone else with save issues please do the same.


Not a save issue. Latest Tahr builds and this Slacko will not boot a fresh frugal install (no savefile). Immediate kernel panic. Will boot from cd with savefile though.

EDIT:
Made a save folder after the live session...... rebooted with cd......Slacko gave choice of 3 Slackosaves...picked the folder and booted no problem.

Immediate kernel panic on regular frugal install though.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 41 [613 Posts]   Goto page: 1, 2, 3, ..., 39, 40, 41 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1249s ][ Queries: 12 (0.0180s) ][ GZIP on ]