Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 01 Aug 2014, 20:34
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
slacko-6.0 beta 2
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 3 of 37 [553 Posts]   Goto page: Previous 1, 2, 3, 4, 5, ..., 35, 36, 37 Next
Author Message
James C


Joined: 26 Mar 2009
Posts: 5687
Location: Kentucky

PostPosted: Wed 18 Jun 2014, 03:20    Post subject:  

Billtoo wrote:
James C wrote:
Other than the minor kernel panic problem things are working pretty well.....


Just wondering, if you go to "/setup/QuickSetup first run settings" and
check the "Run Internet apps as spot" box, does it break the
flashplugin and cause Firefox to crash?


Yes indeed.Confirmed.Crashed pretty fast.Got back to root as quick as I could...... Smile
Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 2063
Location: Ontario Canada

PostPosted: Wed 18 Jun 2014, 03:23    Post subject:  

James C wrote:

Yes indeed.Confirmed.Crashed pretty fast.Got back to root as quick as I could...... Smile


Me too, thanks for responding.
Back to top
View user's profile Send private message 
shinobar


Joined: 28 May 2009
Posts: 2607
Location: Japan

PostPosted: Wed 18 Jun 2014, 04:04    Post subject: CUPS on Slacko-6.0 alpha  

Slacko-6.0 alpha frugal install on ext4 partition.
save-to-direcory works fine.

Encountered same CUPS problem as Tahr pup.
http://www.murga-linux.com/puppy/viewtopic.php?p=782576#782576
# /usr/lib/cups/backend/usb
direct usb://EPSON/EP-704A "EPSON EP-704A" "EPSON EP-704A" "MFG:EPSON;CMD:ESCPL2,BDC,D4,D4PX,ESCPR2;MDL:EP-704A;CLS:PRINTER;DES:EPSON EP-704A;CID:EpsonRGB;FID:FXN,DPN,WFN,ETN,AFN,DAN;" ""

But the CUPS web interface does not show my USB printer on the list of the Local Prnters

With the same hardware, Slacko 5.7 and Precise Puppy 571JP is fine.
But the Slacko-6.0 alpha and Tahr Puppy 5.8.0.8 shows same problem. Crying or Very sad

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html

Last edited by shinobar on Wed 18 Jun 2014, 04:10; edited 2 times in total
Back to top
View user's profile Send private message Visit poster's website 
shinobar


Joined: 28 May 2009
Posts: 2607
Location: Japan

PostPosted: Wed 18 Jun 2014, 04:08    Post subject: mksquashfs  

/usr/sbin/mksquashfs in slacko-6.0 alpha is a link to mksquashfs3.
It is to be a link to mksquashfs4.

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
01micko


Joined: 11 Oct 2008
Posts: 7785
Location: qld

PostPosted: Wed 18 Jun 2014, 04:17    Post subject:  

rcrsn51 wrote:
The most recent version of Legacy GRUB Config 2013 is here.

The version in Slacko 591 has a completely different user interface. How did this happen? Has this modified version become the standard in woof-ce?

What testing did this version get to ensure that nothing broke?

The Help button in the modified version links to the forum page of the official version. So who is taking responsibility for providing user support for the modified version?


I'll revert if you like, however it has been there since 5.7.

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
01micko


Joined: 11 Oct 2008
Posts: 7785
Location: qld

PostPosted: Wed 18 Jun 2014, 04:22    Post subject: Re: mksquashfs  

shinobar wrote:
/usr/sbin/mksquashfs in slacko-6.0 alpha is a link to mksquashfs3.
It is to be a link to mksquashfs4.


Thanks. I am thinking to remove squash3 support by default. It can be added as a package. I intend to update to mksqushfs-4.3.

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
01micko


Joined: 11 Oct 2008
Posts: 7785
Location: qld

PostPosted: Wed 18 Jun 2014, 04:37    Post subject:  

Billtoo. I think the problem is that flash is running with the wrong permissions. I think that flash can be installed on a per user basis so it would install to /spot/.mozilla/firefox/$YOUR_PROFILE/plugins/

If you can move it there, run
Code:
cd /spot/.mozilla/firefox/$YOUR_PROFILE/plugins/
chown spot:spot libflashplayer.so


Or try without inside your profile just in /spot/.mozilla/firefox/plugins/
#Comment: spot has his own group

See how you go. If that's the case then maybe shinobar's getflash can detect if running as spot and move it there automatically.

As far as kde-games go.. I didn't see it in PPM. Have they split it all up? Or was there a mistake an old 14.0 databases were installed? Was there a /usr/share/applications/kde4/ dir created?

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
shinobar


Joined: 28 May 2009
Posts: 2607
Location: Japan

PostPosted: Wed 18 Jun 2014, 05:20    Post subject: xorgwizard and shutdownconfig  

My GeForce GTX660ti shows odd with nouveau driver. The label of the pinboard on the desktop cannot see. (EDIT: "nouveau.modeset=0" boot option saved this.)

I go the xorgwizard and chose vesa. The xorgwizard require reboot PC. But the shutdownconfig is not invoked. Therefore, reboots without saving session.

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
sszindian


Joined: 24 Apr 2010
Posts: 600
Location: Pennsylvania U.S.

PostPosted: Wed 18 Jun 2014, 06:44    Post subject: Tahr  

rcrsn51 - check your PM!

>>>---Indian------>

_________________
Cloud Computing For Every Puppy (a .pet)
http://murga-linux.com/puppy/viewtopic.php?t=69192
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 8939
Location: Stratford, Ontario

PostPosted: Wed 18 Jun 2014, 07:02    Post subject:  

@shinobar: From the Tahr discussion, here is my only suggestion to fix this.

1. Apply the 55-cups.rules patch.
2. Reboot the printer.
3. Confirm that the device node /dev/usb/lp0 has a full set of write permissions.
4. Install in CUPS with the URI: parallel:/dev/usb/lp0
5. Look for error messages.
Back to top
View user's profile Send private message 
OscarTalks

Joined: 05 Feb 2012
Posts: 825
Location: London, England

PostPosted: Wed 18 Jun 2014, 07:59    Post subject:  

Testing Slacko 5.9.1

I posted about the Advert Blocker during the RC phase of 5.7 and I know that really it needs to be addressed at the Woof CE level and/or maybe is not important so apologies if I am speaking out of turn by mentioning it again, but I did have a stab at adding some fixes and updates to it. (mvps still doesn't work and technobeta is still dead).
http://www.murga-linux.com/puppy/viewtopic.php?t=59290&start=53
There seems to be some debate over whether 0.0.0.0 is better than 127.0.0.1 and if so then it will need amending for that.

Also, do we need all those grub4dos menu entries?

_________________
Oscar in England

Back to top
View user's profile Send private message 
SFR


Joined: 26 Oct 2011
Posts: 1047

PostPosted: Wed 18 Jun 2014, 08:14    Post subject:  

@Mick: Some updated stuff you may want to consider...

I dropped you this one via PM a couple of months ago, but perhaps you missed it; updated jwmconfig, with two fixes:
- in 'keyboard' script, 'Edit' and 'Delete' buttons might be disabled (happens in ToOpPy, based on Precise-5.4.3 - Argolance spotted it), unless any item in the <tree> is selected and app's window unfocused and focused back again.
- horizontal distribution of radiobuttons ("Snap mode" frame) in "window" script has been corrected.
(attached)
___________

/usr/sbin/run-pureftpd: tiny, tiny fix for a bug in gettext that prevents final window with some useful info from being displayed
(attached)
___________

Hugely reworked Kirk's pcurlftp_file_sharing app.
Details: http://www.murga-linux.com/puppy/viewtopic.php?p=768235#768235
Recently, I also added lazy unmount (fusermount -z -u ...), so if a user is in the middle of copying from/to a share and close ROX-Filer's window, we can be sure that the share will be unmounted right after copying finished.
(attached)
___________

From other apps:
- defaults-chooser-0.8.9
- gfnrename-0.6 hacked
- peasyglue-1.7
- peasypdf-3.1
- peasyprint-2.6
___________

Compiled (and I don't like compiling) by myself, so verification is welcomed.
- unrar-5.10 (attached)
- gifsicle-1.83 (attached)
- mhwaveedit-1.4.23 (attached)
___________

Oh, there's still that broken symlink in devx.sfs (I wonder how it got there?? Laughing ):
/root/.config/rox.sourceforge.net/OpenWith/application_x-cd-image/Burn with pBurn

Greetings!
jwmconfig3-140429.pet
Description 
pet

 Download 
Filename  jwmconfig3-140429.pet 
Filesize  18.31 KB 
Downloaded  20 Time(s) 
run-pureftpd.tar.gz
Description  Goes to /usr/sbin/
gz

 Download 
Filename  run-pureftpd.tar.gz 
Filesize  879 Bytes 
Downloaded  15 Time(s) 
pcurlftp_file_sharing-0.2-1.pet
Description 
pet

 Download 
Filename  pcurlftp_file_sharing-0.2-1.pet 
Filesize  35.21 KB 
Downloaded  19 Time(s) 
unrar-5.10-i386.pet
Description 
pet

 Download 
Filename  unrar-5.10-i386.pet 
Filesize  128.95 KB 
Downloaded  18 Time(s) 
gifsicle-1.83.pet
Description 
pet

 Download 
Filename  gifsicle-1.83.pet 
Filesize  146.76 KB 
Downloaded  17 Time(s) 
gifsicle_DOC-1.83.pet
Description 
pet

 Download 
Filename  gifsicle_DOC-1.83.pet 
Filesize  13.02 KB 
Downloaded  19 Time(s) 
mhwaveedit-1.4.23.pet
Description 
pet

 Download 
Filename  mhwaveedit-1.4.23.pet 
Filesize  218.54 KB 
Downloaded  17 Time(s) 
mhwaveedit_DOC-1.4.23.pet
Description 
pet

 Download 
Filename  mhwaveedit_DOC-1.4.23.pet 
Filesize  1.05 KB 
Downloaded  18 Time(s) 
mhwaveedit_NLS-1.4.23.pet
Description 
pet

 Download 
Filename  mhwaveedit_NLS-1.4.23.pet 
Filesize  179.56 KB 
Downloaded  19 Time(s) 

_________________
[O]bdurate [R]ules [D]estroy [E]nthusiastic [R]ebels => [C]reative [H]umans [A]lways [O]pen [S]ource
Omnia mea mecum porto.
Back to top
View user's profile Send private message 
shinobar


Joined: 28 May 2009
Posts: 2607
Location: Japan

PostPosted: Wed 18 Jun 2014, 08:36    Post subject: CUPS on Slacko-6.0 alpha  

rcrsn51 wrote:
@shinobar: From the Tahr discussion, here is my only suggestion to fix this.

1. Apply the 55-cups.rules patch.
2. Reboot the printer.
3. Confirm that the device node /dev/usb/lp0 has a full set of write permissions.
4. Install in CUPS with the URI: parallel:/dev/usb/lp0
5. Look for error messages.

55-cups.rules patch is already applied on the Slacko 5.9.1.
# ls -l /dev/usb/lp0
crw-rw-rw- 1 root lp 180, 0 Jun 18 06:57 /dev/usb/lp0

# /usr/lib/cups/backend/usb
direct usb://EPSON/EP-704A "EPSON EP-704A" "EPSON EP-704A" "MFG:EPSON;CMD:ESCPL2,BDC,D4,D4PX,ESCPR2;MDL:EP-704A;CLS:PRINTER;DES:EPSON EP-704A;CID:EpsonRGB;FID:FXN,DPN,WFN,ETN,AFN,DAN;" ""

I edited /etc/cups/cupsd.conf to get more debugging info:
# Log general information in error_log - change "info" to "debug" for
# troubleshooting...
LogLevel debug

I followed your suggestion:
1. Run CUPS. Under Add Printer, select AppSocket/JetDirect.
2. On the next screen, delete "socket" and type "parallel:/dev/usb/lp0"

Seems installed printer named 'lp'.
Tried printing test page from the web interface. Nothing the printer do.

Got /var/log/cups/error_log:
EDIT: Somewhat i mistook in CUPS error_log, but the Web interface says "Unable to open device file "/dev/usb/lp0": Permission denied"

Again checked the permission:
# ls -l /dev/usb/lp0
crw-rw-rw- 1 root lp 180, 0 Jun 18 06:57 /dev/usb/lp0

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
ally


Joined: 19 May 2012
Posts: 835
Location: lincoln

PostPosted: Wed 18 Jun 2014, 09:37    Post subject:  

booted fine from hdd frugal install on lenovo t500, display and ethernet connection configured automatically

fells snappy, off to play

Smile
Back to top
View user's profile Send private message Visit poster's website 
SFR


Joined: 26 Oct 2011
Posts: 1047

PostPosted: Wed 18 Jun 2014, 09:43    Post subject:  

RE: Firefox as spot + Flash = crash

Aaa, it's an old problem that resurfaced again:
http://murga-linux.com/puppy/viewtopic.php?p=712456#712456
http://murga-linux.com/puppy/viewtopic.php?p=712556#712556
Works fine with corrected permissions.

Greetings!

_________________
[O]bdurate [R]ules [D]estroy [E]nthusiastic [R]ebels => [C]reative [H]umans [A]lways [O]pen [S]ource
Omnia mea mecum porto.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 3 of 37 [553 Posts]   Goto page: Previous 1, 2, 3, 4, 5, ..., 35, 36, 37 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1017s ][ Queries: 12 (0.0122s) ][ GZIP on ]