Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 21 Jul 2017, 00:39
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff)
Fatdog64 Contributed Packages and SFS
Post new topic   Reply to topic View previous topic :: View next topic
Page 11 of 14 [197 Posts]   Goto page: Previous 1, 2, 3, ..., 9, 10, 11, 12, 13, 14 Next
Author Message
step

Joined: 04 May 2012
Posts: 888

PostPosted: Mon 06 Mar 2017, 16:21    Post subject:  

@jake29, thanks.
@smokey01, nice app, thank you. Have you figure out a way to import notecase files into cherrytree?

_________________
Fatdog64-710|+Packages|Findnrun|+forum|gtkmenuplus
Back to top
View user's profile Send private message 
smokey01


Joined: 30 Dec 2006
Posts: 2575
Location: South Australia

PostPosted: Mon 06 Mar 2017, 19:27    Post subject:  

step wrote:
@jake29, thanks.
@smokey01, nice app, thank you. Have you figure out a way to import notecase files into cherrytree?


Yes, click on import and select notecase file Laughing

_________________
Software <-> Distros <-> Tips <-> Newsletters
Back to top
View user's profile Send private message Visit poster's website 
step

Joined: 04 May 2012
Posts: 888

PostPosted: Tue 07 Mar 2017, 06:32    Post subject:  

smokey01 wrote:
Yes, click on import and select notecase file Laughing
You're my god!
_________________
Fatdog64-710|+Packages|Findnrun|+forum|gtkmenuplus
Back to top
View user's profile Send private message 
jamesbond

Joined: 26 Feb 2007
Posts: 3051
Location: The Blue Marble

PostPosted: Sat 11 Mar 2017, 07:53    Post subject:  

Upload Java JDK 8u121, get it from SFS Manager or from here: http://distro.ibiblio.org/fatdog/sfs/710/. It is listed in 710 but it's actually version-agnostic and can be used by earlier versions as well.

EDIT2: I have re-uploaded the 4.4.52-rt63 kernel. This kernel is configured for low-latency work, such as audio recording etc. It is patched with rt (real-time) patches, and is configured for PREEMPT_RTB (Basic RT). This is somewhere between "low-latency" kernel and "fully preemptible". The fully preemptible kernel - which I uploaded previously - didn't work; it was too unstable and had unpredictable lockups too often for comfort.

It's here: http://distro.ibiblio.org/fatdog/kernels/710 and as above (from SFS Manager). Guide to replace kernel: http://distro.ibiblio.org/fatdog/web/faqs/kernel.html

_________________
Fatdog64, Slacko and Puppeee user. Puppy user since 2.13.
Contributed Fatdog64 packages thread.
Back to top
View user's profile Send private message 
Gobbi

Joined: 09 Mar 2012
Posts: 231

PostPosted: Wed 15 Mar 2017, 15:47    Post subject:  

This is
Xfce4-4.10-x86_64-710.sfs - sha1 : 0b6031397f2aeb16a6a2357caa4eaebf118b8b9c
More than half of it , it's from the repo , so you might have perl,gstreamer,gvfs and some libraries loaded already . No gtk3 . I separated the locales from the main sfs . I borrowed from puppy community and I thank for XfcePowerTools , pup-volume-monitor , window manager switcher and the shutdown-gui script .

First of all : Once loaded and started , I couldn't unload the sfs ; in terminal I got "Device or resource busy" . Do make a backup of your savefile or try it with no savefile Exclamation
To start - after loading the sfs , right-click for menu : Desktop -> A WM Switcher .
After starting Xfce you will see warnings , because sven already takes care of some keybindings . To get rid of warnings you should choose which program should take care of those keybindings : right-click on sven's icon from the panel or Xfce Menu -> Settings -> Keyboard -> Shortcuts .
I suggest to install at least one more icon theme , for instance gnome icon theme from the repo is a valid one . I made some initial settings and put in a few plugins and apps.
A separate tarball for locales with packages in it :
Xfce4-4.10-nls-x86_64-710.tar.xz - sha1 : c543421f4e603b5de2d8ed5fbb70172e4d4e0577

I have chosen Xfce4-4.10 because I had problems with Xfce4-4.12 . The icon theme I could change it only manually with no GUI , editing /root/.gtkrc.mine file . Only from Change theme GTK theme chooser from Fatdog's Control Panel I was able to change themes and Xfce4-4.12 it's fatter too : it also loads gtk3 and deps , gstreamer2 and its plugins.

Last edited by Gobbi on Yesterday, at 14:27; edited 1 time in total
Back to top
View user's profile Send private message 
step

Joined: 04 May 2012
Posts: 888

PostPosted: Sat 18 Mar 2017, 14:42    Post subject:  

Recent uploads for Fatdog64-710:

All my package uploads: see the link in my signature.

_________________
Fatdog64-710|+Packages|Findnrun|+forum|gtkmenuplus
Back to top
View user's profile Send private message 
WillM

Joined: 30 Dec 2009
Posts: 171
Location: Oakland, California

PostPosted: Fri 24 Mar 2017, 13:45    Post subject: Aisleriot Solitaire  

aisleriot-3.12.1-x86_64.sfs
md5sum: cdcbd3638faf3588d4486386dd6e7b4f

https://drive.google.com/drive/folders/0B4wlewvEGCtKZ0tYclNqNEV4NkU?usp=sharing

After loading this sfs for the first time it may be necessary to run the following from a terminal;
Code:
glib-compile-schemas /usr/share/glib-2.0/schemas

Last edited by WillM on Sun 09 Apr 2017, 14:36; edited 1 time in total
Back to top
View user's profile Send private message 
step

Joined: 04 May 2012
Posts: 888

PostPosted: Sun 26 Mar 2017, 04:41    Post subject:
Subject description: rxvt-unicode_perl 9.22 with 256 colors and extensions
 

Rxvt Unicode 9.22 (perl). If you are a console hound this package should appeal to you. It's the urxvt terminal with support for 256 colors, and pre-configured with perl extensions for named tabs, clickable URLs, on-the-fly font resizing, scroll buffer text search, and more. Install from package manager. It installs into /usr/local so it coexists with the base urxvt package. Perl 5.20.00 is required for installation and use. You can either install perl from the package manager, or load the devx sfs, which includes perl (recommended).

This package appends a section to your ~/.Xresources file. After installing start /usr/local/bin/urxvt and test the new features:

  • C-A-s - search backwards in the scroll buffer. Up/Down Arrow keys jump to the next match. Escape exits search mode.
  • C-Up and C-Down - enlarge/shrink the font size. Tip: resize with unmaximized window then maximize it.
  • C-/ (slash) - show current font info.
  • C-= (equal) - select default font (applies to current tab).
  • S-Down - open new tab (repeat for more). To close the window close individual tabs with C-D or "exit".
  • S-Left/Right - switch to previous/next tab.
  • S-Up - rename tab, Escape exits, Enter renames.
  • Ctrl+middle-mouse button - display urxvt option menu.
  • Ctrl+right-mouse - display clipboard menu (first select some text in the terminal).
  • Clickable URLs are automatically highlighted. Clicking starts "defaultbrowser" (configurable in ~/.Xresources). To create test material type echo http://murga-linux.com/puppy and press Enter. Click the output.
  • C-A-u - search URLs in scroll buffer. Up/Down jumps to previous/next match. Enter activates browser on current match. y copies match to clipboard. More key bindings in ~/.Xresources.


The base rxvt package supports 88 colors only - which isn't bad. However, many good color schemes need 256 colors, especially if you want to use - without complications - the same color scheme in your terminal and in some graphical applications.

_________________
Fatdog64-710|+Packages|Findnrun|+forum|gtkmenuplus
Back to top
View user's profile Send private message 
step

Joined: 04 May 2012
Posts: 888

PostPosted: Sat 01 Apr 2017, 17:18    Post subject:
Subject description: master pdf editor Qt5
 

Master PDF Editor (commercial/free for non-commercial use). The program is mentioned in this post with links to the vendor's page. I downloaded the 64-bit Qt5 .deb package (free for non-commercial use), clicked the downloaded file to open it with the default archiver program, and dragged the folder "masterpdfeditor...amd64" to an empty folder. Then I created an SFS package of the "masterpdfeditor...amd64 folder, and loaded it from the rox right-click menu. The program runs fine -- I have only tested a couple of functions. It's able to display some PDF documents that evince can't show at all.
_________________
Fatdog64-710|+Packages|Findnrun|+forum|gtkmenuplus
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 1387
Location: Italy

PostPosted: Fri 07 Apr 2017, 13:44    Post subject: skypeforlinux  

skypeforlinux_5.0.0.5_amd64.deb from:

https://repo.skype.com/deb/pool/main/s/skypeforlinux/

works in fatdog64-710 and the other puppies in development. I'm not sure if it needs libgnome-keyring: I do not remember if I already installed it. I have manually repackaged it in txz format because the automated procedure has a failure. Now I'm going to test the last release 5.1.0.1 on 04/04/2017.
Back to top
View user's profile Send private message 
step

Joined: 04 May 2012
Posts: 888

PostPosted: Fri 07 Apr 2017, 15:22    Post subject:  

Thanks watchdog. It does seem to depend on libgnome-keyring, which isn't found in the Fatdog64 repos. You probably manually installed the missing dependency from one of these packages. Here's the deb control file:
Code:

Package: skypeforlinux
Version: 5.1.0.1
Architecture: amd64
Maintainer: Skype Technologies S.A. <info@skype.net>
Installed-Size: 160932
Depends: gconf-service, libasound2 (>= 1.0.16), libatk1.0-0 (>= 1.12.4), libc6 (>= 2.9), libcairo2 (>= 1.6.0), libcups2 (>= 1.4.0), libdbus-1-3 (>= 1.1.4), libexpat1 (>= 2.0.1), libfontconfig1 (>= 2.11), libfreetype6 (>= 2.4.2), libgcc1 (>= 1:4.1.1), libgconf-2-4 (>= 3.2.5), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.31.8), libgnome-keyring0 (>= 2.22.2), libgtk2.0-0 (>= 2.24.0), libnspr4 (>= 2:4.9-2~), libnss3 (>= 2:3.13.4-2~), libpango-1.0-0 (>= 1.14.0), libpangocairo-1.0-0 (>= 1.14.0), libstdc++6 (>= 4.6), libx11-6 (>= 2:1.4.99.1), libx11-xcb1, libxcb1 (>= 1.6), libxcomposite1 (>= 1:0.3-1), libxcursor1 (>> 1.1.2), libxdamage1 (>= 1:1.1), libxext6, libxfixes3, libxi6 (>= 2:1.2.99.4), libxrandr2 (>= 2:1.2.99.3), libxrender1, libxss1, libxtst6, gnome-keyring, apt-transport-https
Section: non-free/net
Priority: extra
Homepage: https://www.skype.com

_________________
Fatdog64-710|+Packages|Findnrun|+forum|gtkmenuplus
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 1387
Location: Italy

PostPosted: Sat 08 Apr 2017, 05:21    Post subject:  

step wrote:
Thanks watchdog. It does seem to depend on libgnome-keyring, which isn't found in the Fatdog64 repos.


If libgnome-keyring is required by later releases of skypeforlinux beta install this one:

http://mirrors.slackware.com/slackware/slackware64-14.1/slackware64/l/libgnome-keyring-3.8.0-x86_64-1.txz
Back to top
View user's profile Send private message 
step

Joined: 04 May 2012
Posts: 888

PostPosted: Mon 10 Apr 2017, 17:00    Post subject:
Subject description: keepassxc 2.1.3
 

KeePassXC 2.1.3 password manager - cross-platform community-driven port of the Windows application “Keepass Password Safe”. Install from package manager.
_________________
Fatdog64-710|+Packages|Findnrun|+forum|gtkmenuplus
Back to top
View user's profile Send private message 
jake29

Joined: 24 Jul 2015
Posts: 72

PostPosted: Sun 16 Apr 2017, 11:31    Post subject: Wine 2.6
Subject description: Latest Build
 

Here are the package and sfs for the latest available build of Wine.

wine-2.6-i686-1.txz (204mb)
wine-2.6-710-1.sfs (223mb)
Back to top
View user's profile Send private message 
step

Joined: 04 May 2012
Posts: 888

PostPosted: Tue 18 Apr 2017, 08:50    Post subject: Re: Wine 2.6
Subject description: Latest Build
 

jake29 wrote:
Here are the package and sfs for the latest available build of Wine.
Thank you, much appreciated.
_________________
Fatdog64-710|+Packages|Findnrun|+forum|gtkmenuplus
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 11 of 14 [197 Posts]   Goto page: Previous 1, 2, 3, ..., 9, 10, 11, 12, 13, 14 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1397s ][ Queries: 14 (0.0101s) ][ GZIP on ]