Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 16 Sep 2014, 05:44
All times are UTC - 4
 Forum index » House Training » HOWTO ( Solutions )
Disable GTK "recently used files"
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [6 Posts]  
Author Message
cimarron

Joined: 30 May 2013
Posts: 99

PostPosted: Sat 13 Sep 2014, 18:40    Post subject:  Disable GTK "recently used files"
Subject description: i.e. /root/.local/share/recently-used.xbel
 

It took me a while to find the solution to this, and lots of other linux users have searched for it as well (including this puppy thread). There's a file, /root/.local/share/recently-used.xbel, that gtk uses to log files you've opened. It's used by many applications and can hold quite a length of history. This is also what's referenced when opening a file and selecting "recently used" in the dialog.

If you delete recently-used.xbel, it's quickly replaced. If you change write permissions, those are overridden. You can use "chattr +i" to prevent writing to it, but apparently a temp file is written first and this will result in lots of disk writes as it attempts again and again to write to recently-used.xbel (there can also be lots of errors displayed if certain applications are run in terminal, as they keep trying to write to this file).

But for GTK2, which I think most puppies use, the logging can be stopped if this line is added to /root/.gtkrc.mine:
Code:
gtk-recent-files-max-age=0

I think GTK needs to be restarted for this setting to be used. I just changed the GTK theme and changed back, and it worked. The recently-used.xbel file is still created, but it holds no data.

To revert to normal logging, just remove that line (and restart GTK).
Back to top
View user's profile Send private message 
MochiMoppel


Joined: 26 Jan 2011
Posts: 393
Location: Japan

PostPosted: Sat 13 Sep 2014, 22:05    Post subject: Re: Disable GTK "recently used files"
Subject description: i.e. /root/.local/share/recently-used.xbel
 

Just curious: Why do you want to disable it? I understand that there are many users who want the same, but I've seen other threads where users asked to make this file more accessible. In the thread you mentioned tha the OP was concerned about the size of the file. Can't this be controlled by a value of 1 or 2 (days?)?
Back to top
View user's profile Send private message 
cimarron

Joined: 30 May 2013
Posts: 99

PostPosted: Sat 13 Sep 2014, 22:17    Post subject:  

For some people there's also a privacy concern, especially if the computer is used by more than one person. Similar to not wanting to be tracked by Ubuntu's zeitgeist.

I'm not sure if I want to keep the "recently used" functionality or not. But I like to be able to turn it off.
Back to top
View user's profile Send private message 
MochiMoppel


Joined: 26 Jan 2011
Posts: 393
Location: Japan

PostPosted: Sun 14 Sep 2014, 08:34    Post subject:  

cimarron wrote:
For some people there's also a privacy concern, especially if the computer is used by more than one person.
People who share their private pupsave file with persons they don't trust should certainly be concered Laughing OK, but that's a different topic.
Quote:
But I like to be able to turn it off.
Yes, it's always good to be in control. Even if turning off might be a bit drastic, turning it down sounds like a good idea. The default is 30 days. That's a long time to accumulate a massive amount of data. Setting it to 2-3 days seems more appropriate.

It is also possible to limit the number of recently used files that appear in the Open/Save dialog:
Code:
gtk-recent-files-limit=20
limits the number to 20. Default is 50.
Back to top
View user's profile Send private message 
cimarron

Joined: 30 May 2013
Posts: 99

PostPosted: Sun 14 Sep 2014, 10:05    Post subject:  

Does the gtk-recent-files-limit setting work for GTK2? I've seen it recommended as a GTK3 solution, but I think when I tried it there was no effect (or maybe it just doesn't work to set it to 0?).
Back to top
View user's profile Send private message 
MochiMoppel


Joined: 26 Jan 2011
Posts: 393
Location: Japan

PostPosted: Sun 14 Sep 2014, 10:37    Post subject:  

cimarron wrote:
Does the gtk-recent-files-limit setting work for GTK2? I've seen it recommended as a GTK3 solution, but I think when I tried it there was no effect (or maybe it just doesn't work to set it to 0?).
Yes,it works for GTK2. It's even older than the gtk-recent-files-max-age setting, however as both settings share the same file gtk-recent-files-limit will also result in zero (no matter what value is set) if you set gtk-recent-files-max-age=0. In fact this seems to be the only way to set the Open/Save files to zero. When I tried
Code:
gtk-recent-files-max-age=2
gtk-recent-files-limit=0

the Open/Save dialog still shows 1 file
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [6 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » HOWTO ( Solutions )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0575s ][ Queries: 11 (0.0069s) ][ GZIP on ]