Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 14 Dec 2018, 19:32
All times are UTC - 4
 Forum index » Taking the Puppy out for a walk » Misc
How to add a Ubuntu repository to ppm?
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 2 [16 Posts]   Goto page: Previous 1, 2
Author Message

Joined: 02 Sep 2014
Posts: 1316

PostPosted: Wed 22 Nov 2017, 02:52    Post subject:  

mavrothal wrote:
It works OK at my end.
I tried it on Puppy Tahr and only with the kxstudio and as the picture shows works fine.
What I did was to add
in DISTRO_COMPAT_REPOS then open PPM and update the databases from "settings"
Closed PPM.
Removed the previous PPM files from /tmp (or just reboot) as I find that they mess up the process if they are (partially) overwritten.
Opened PPM again, activated the kxstudio repo from "settings",
Closed and reopened PPM one last time for the change to take effect, and that was it.

The trick is that you must add the "Packages-${DISTRO_BINARY_COMPAT}-${DISTRO_COMPAT_VERSION-<name>" or "Packages-ubuntu-trusty-<name>" or at least "Packages-<name>" because the database file is generated from /root/.packages/Packages-*. Without "Packages" does not see it as a repo.

BTW I see you add a bunch of x86_64 repos. Do you have a 64bit Ubuntu Puppy or you are going to use them with other 64bit puppies?

I tried to add the xenial repository on tahrpup and it didn't quite work out for me. The update db worked without error. It created all the related files (e.g. ~/.package/Packages-ubuntu-xenial-universe)

However when I searched for a package (e.g. synergy) the description and package name were blank. Here is how I modified DISTRO_COMPAT



#REPOS_DISTRO_COMPAT - hardcode the compat-distro repos in here...
# 1|2|3
#   1 - domain. for testing the url.
#   2 - full URI of the repo
#   3 - name of db-file(s) associated with that repo. it may have glob wildcards.


ubuntu-xenial-main seemed to work but the other ones look blank when I look in the puppy package manager.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 2 [16 Posts]   Goto page: Previous 1, 2
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Taking the Puppy out for a walk » Misc
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0334s ][ Queries: 14 (0.0093s) ][ GZIP on ]