Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 18 Dec 2014, 19:10
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
[Résolu] Editeur Gvim sous Puppy
Moderators: Béèm, darkerror05
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [14 Posts]  
Author Message
jopervasco

Joined: 25 Mar 2011
Posts: 321

PostPosted: Sat 22 Nov 2014, 09:56    Post subject:  [Résolu] Editeur Gvim sous Puppy  

Bonjour
j'ai installé Vim sous Puppy et ça marche bien. Smile
par contre je n'ai pas trouvé pour installer cela en mode graphique. (Slacko 5.3)

j'aimerai (et peut-être d'autre aussi) avoir l'équivalent de l’installation de vim-gtk sous debian par exemple

merci

sous Debian Raspberry (via puppy..) voilà ce que ça donne
raspberry2.png
 Description   
 Filesize   75.44 KB
 Viewed   129 Time(s)

raspberry2.png


_________________
Slacko 5.3.3 vraiment sympa Smile

Last edited by jopervasco on Sun 30 Nov 2014, 12:24; edited 1 time in total
Back to top
View user's profile Send private message 
Médor


Joined: 26 May 2011
Posts: 1838

PostPosted: Sat 22 Nov 2014, 12:18    Post subject:  

Bonjour jopervasco,

Ici dans le PPM de Slacko-5.7.0 j'ai bien un paquet vim-gvim-7.3.645 Wink
PPM » Rechercher : gvim ...

Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto Toutou
Back to top
View user's profile Send private message 
jopervasco

Joined: 25 Mar 2011
Posts: 321

PostPosted: Mon 24 Nov 2014, 04:02    Post subject:  

Bonjour
merci de la réponse

oui ma base ppm n'était pas à jour et les paquets était sur Slackware.

désolé mais je n'y avais pas pensé sur ce coup là..

pour Vim
vim-7.3.154-i486-1.txz
gpm-1.20.1-i486-5.txz
et ça marche bien

pour gvim
vim-gvim-7.3.154-i486-1.txz
gpm-1.20.1-i486-5.txz
lib2-2.28.6-i486-1.txz
et là ça ne marche pas Sad
Quote:
# gvim
gvim: error while loading shared libraries: libpython2.6.so.1.0: cannot open shared object file: No such file or directory


de plus quand j'ouvre une console j'ai maintenant ce message là
Quote:
bash: /etc/profile.d/libglib2.csh.new: line 28: syntax error: unexpected end of file


ce n'est pas facile tous les jours le monde libre Wink

Bonne journée à tous

_________________
Slacko 5.3.3 vraiment sympa Smile
Back to top
View user's profile Send private message 
jopervasco

Joined: 25 Mar 2011
Posts: 321

PostPosted: Mon 24 Nov 2014, 09:14    Post subject:  

Bonjour

En fait c'était sur une installation "neuve" et j'avais oublié d'installer le paquet devx_slacko_5.3.3.pet
maintenant gvim fonctionne
par contre j'ai toujours le message en ouvrant la console :
Code:
bash: /etc/profile.d/libglib2.csh.new: line 28: syntax error: unexpected end of file


je peux peut-être supprimer ce fichier mais je ne sais pas à quoi il sert
Back to top
View user's profile Send private message 
Médor


Joined: 26 May 2011
Posts: 1838

PostPosted: Mon 24 Nov 2014, 10:02    Post subject:  

Bonjour jopervasco,

En effet sous Puppy python se trouve dans le devx.
Il semble que le paquet pour la glib soit le coupable, un lien aurai peut-être suffit !
Puisque tu as synchronisé les dépôts dans le PPM, tu peux cependant en profiter pour installer la mise à jour de sécurité de bash depuis le dépôt slackware et éviter aussi les erreurs de syntaxe Exclamation

Slacko n'est pas Slackware, idem pour Lucid, Precise, etc. vis à vis d'Ubuntu !
Ça ne fonctionne pas à tous les coups, c'est pour cela qu'il vaut mieux compiler ses applications sur sa version de Puppy Wink


Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto Toutou
Back to top
View user's profile Send private message 
jopervasco

Joined: 25 Mar 2011
Posts: 321

PostPosted: Mon 24 Nov 2014, 16:07    Post subject:  

Bonjour Médor

j'ai installé Bash 4.1 mais je ne sais pas si c'est de cela que tu parlais ?
en tous cas ça ne règle pas le message quand j'ouvre xterm
bash.png
 Description   
 Filesize   3.86 KB
 Viewed   68 Time(s)

bash.png


_________________
Slacko 5.3.3 vraiment sympa Smile
Back to top
View user's profile Send private message 
Médor


Joined: 26 May 2011
Posts: 1838

PostPosted: Mon 24 Nov 2014, 17:32    Post subject:  

Bonsoir jopervasco,

D'après Slackware Security il faut installer sur Slackware 13.37 : bash-4.1.012-i486-1_slack13.37.txz
Si tu as toujours l'erreur, Il faudrait que tu supprimes le paquet lib2-2.28.6-i486-1.txz pour rétablir les fichiers originaux de slacko et voir à faire un lien pour satisfaire Gvim Exclamation

Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto Toutou
Back to top
View user's profile Send private message 
jopervasco

Joined: 25 Mar 2011
Posts: 321

PostPosted: Tue 25 Nov 2014, 03:24    Post subject:  

Bonjour Médor

ton lien ne marchait pas mais cherchant j'ai installé en lieu et place le paquet suivant bash-4.1.017-i486-1_slack13.37.txz (je pense que le 017 est plus à jour que le 012 ? )
sur ftp://ftp.slackware.com/pub/slackware/slackware-13.37/patches/packages/

sinon il y a le même message dans la console au démarrage

Nb je ne savais pas que Puppy Slacko 5.3.3 était basée sur cette version /slackware-13.37 (Comment fait-on pour savoir sur quelle distribution est dérivée une Puppy ?)

_________________
Slacko 5.3.3 vraiment sympa Smile
Back to top
View user's profile Send private message 
Médor


Joined: 26 May 2011
Posts: 1838

PostPosted: Tue 25 Nov 2014, 07:29    Post subject:  

Bonjour jospervasco,

Pour l'erreur de /etc/profile.d/libglib2.csh.new tu peux retirer les droits d'exécution de ce script Exclamation
Il y a un autre script /etc/profile.d/libglib2.sh.new qui utilise l'interpréteur sh, ce script est-il exécutable Question
Voir ensuite si l'erreur persiste au reboot ...

Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto Toutou
Back to top
View user's profile Send private message 
jopervasco

Joined: 25 Mar 2011
Posts: 321

PostPosted: Tue 25 Nov 2014, 09:20    Post subject:  

bonjour Médor
pour le script j'ai retiré les droits d'execution

Quote:
# ls -l /etc/profile.d/libglib2.csh.new
-rw-r--r-- 1 root root 999 2011-03-27 23:04 /etc/profile.d/libglib2.csh.new

mais ça n'a rien changé mais en relançant le serveur x

alors j'ai créé un répertoire /root/bad dans lequel j'ai déplacé le script
Quote:
# mkdir ~/bad
# mv /etc/profile.d/libglib2.csh.new ~/bad/


et là plus d'erreur...

tu penses que c'est la bonne méthode ? avant un éventuel delete de ce fichier ?

Ce n'est quand même pas fait pour les les débutants d'installer un programme... Wink

en tout cas un grand merci

_________________
Slacko 5.3.3 vraiment sympa Smile
Back to top
View user's profile Send private message 
Médor


Joined: 26 May 2011
Posts: 1838

PostPosted: Wed 26 Nov 2014, 17:15    Post subject:  

Bonsoir jospervasco,

J'ai regardé de plus près le contenu du sfs principal de slacko-5.3.3-t, je ne comprends pas pourquoi tu as installé le paquet glib2-2.28.6-i486-1.txz Exclamation
Ces libs sont déjà présentes, même numéro de version...
Après avoir changé des permissions de fichiers dans /etc, le plus simple est de rebooter Exclamation
Tu peux supprimer le script /etc/profile.d/libglib2.csh.new Exclamation

Ici le paquet gvim de slackware-14.0 fonctionne sur Slacko-5.7.0 (avec le devx pour python) juste en ajoutant le paquet gpm...

Pour connaitre la version de la distribution dérivée compatible, voir le contenu du fichier /initrd/DISTRO_SPECS
Ex :
Code:
# cat /initrd/DISTRO_SPECS | grep 'DISTRO'
DISTRO_NAME='Slacko Puppy'
DISTRO_VERSION=5.7.0
DISTRO_BINARY_COMPAT='slackware'
DISTRO_FILE_PREFIX='slacko'
DISTRO_COMPAT_VERSION='14.0'
DISTRO_KERNEL_PET='linux_kernel-3.10.32-slacko_PAE.pet'
DISTRO_TARGETARCH='x86'
DISTRO_XORG_AUTO='yes'
DISTRO_DB_SUBNAME='slacko14'
DISTRO_IDSTRING='s140309082357ZZZZ5.7.0XXXXXXXXXX'
DISTRO_PUPPYSFS='puppy_slacko_5.7.0.sfs'
DISTRO_ZDRVSFS='zdrv_slacko_5.7.0.sfs'
DISTRO_PUPPYDATE='Mar 2014'
#

Le gestionnaire des paquets (PPM) l'indique aussi.


Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto Toutou
Back to top
View user's profile Send private message 
jopervasco

Joined: 25 Mar 2011
Posts: 321

PostPosted: Wed 26 Nov 2014, 18:12    Post subject:  

Bonsoir Médor

Médor wrote:
Bonsoir jospervasco,

J'ai regardé de plus près le contenu du sfs principal de slacko-5.3.3-t, je ne comprends pas pourquoi tu as installé le paquet glib2-2.28.6-i486-1.txz Exclamation
[..]



quand j'ai voulu installé Gvim et examinant les dépendances PPM m'a proposé d'installer. Je pensais qu'il ne proposait que si ce n'était pas déjà installé (je lis mal l'anglais...)

sinon :
Quote:
# cat /initrd/DISTRO_SPECS | grep 'DISTRO'
cat: /initrd/DISTRO_SPECS: No such file or directory



Merci pour tes recherches

Bien à toi
dependances.png
 Description   
 Filesize   55.01 KB
 Viewed   24 Time(s)

dependances.png


_________________
Slacko 5.3.3 vraiment sympa Smile
Back to top
View user's profile Send private message 
Médor


Joined: 26 May 2011
Posts: 1838

PostPosted: Wed 26 Nov 2014, 18:58    Post subject:  

le répertoire /initrd n'existe pas sur une installation en "full", le fichier DISTRO_SPECS est aussi disponible dans /etc.

La liste des dépendances est indicative, mais lors de la finalisation de l'installation d'un paquet il y a une recherche indiquant graphiquement l'état des dépendances.


Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto Toutou
Back to top
View user's profile Send private message 
jopervasco

Joined: 25 Mar 2011
Posts: 321

PostPosted: Sun 30 Nov 2014, 12:24    Post subject:  

Bonjour Médor
Tout est résolu grâce à tes conseils
alors encore merci Smile

_________________
Slacko 5.3.3 vraiment sympa Smile
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [14 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0793s ][ Queries: 12 (0.0043s) ][ GZIP on ]