Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 19 Nov 2019, 23:54
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Puli 32/64 bit
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 17 of 18 [262 Posts]   Goto page: Previous 1, 2, 3, ..., 15, 16, 17, 18 Next
Author Message
gjuhasz


Joined: 29 Sep 2008
Posts: 396

PostPosted: Fri 15 Feb 2019, 10:10    Post subject: Announcement: Puli 7
Subject description: 64-bit system with minor improvements in the feature set
 

Dear Puli users,


I am proud to announce the 64-bit Puli 7.0.

The main files are available at http://smokey01.com/gjuhasz/Puli-7.0_Feb2019/.

Installation instructions and detailed description of the new version can be found at http://smokey01.com/gjuhasz/readme-Puli7.html and on the first page of this forum thread.

External 32/64 bit packages have been moved to the shared folder structure at

https://drive.google.com/drive/folders/1GTuMK6jq3BCcZhs6sZ2cDUFmGU8pYtlN


Changes beyond the 64-bit upgrade will be added soon. By then, you can find the changes by comparing the readme files of Puli 7 and the earlier Pulis at

http://www.smokey01.com/gjuhasz.


Have fun!

Regards,

gjuhasz
Back to top
View user's profile Send private message 
gjuhasz


Joined: 29 Sep 2008
Posts: 396

PostPosted: Mon 25 Feb 2019, 19:44    Post subject: Puli 7 mirror  

Dear Puli users,

The main Puli files are mirrored at

https://sourceforge.net/projects/puppyszoftver/files/Puli/

Kudos to skami, the owner/maintainer of Hungarian gold mines https://sourceforge.net/projects/puppyszoftver/ and https://skamilinux.hu/.


Have fun!

Regards,

gjuhasz
Back to top
View user's profile Send private message 
gjuhasz


Joined: 29 Sep 2008
Posts: 396

PostPosted: Sat 09 Mar 2019, 21:35    Post subject: Chrome
Subject description: Updated to accept the official Chrome .deb package
 

Dear Puli users,

Now, the 64-bit Puli 7 supports Google Chrome.

You can (smart)load and use the official google-chrome-stable_current_amd64.deb - Puli runs the latest Chrome (as spot) without any issue.

Only a few files have been changed in Puli, so you don't need to download the whole Puli_install.zip package again.
You can find the changes in the ServicePack folder. Copy the whole structure of the _bootdevice_.zip file to your boot device as follows:
    <boot device>/patch/usr/bin/irrona
    <your boot device>/patch/usr/bin/irronv
    <your boot device>/patch/usr/local/bin/defaultbrowser
    <your boot device>/patch/usr/local/bin/defaulthtmlviewer
    <your boot device>/patch/usr/share/doc/index.html
    <your boot device>/profiles/3-lazy/usr/local/bin/defaultbrowser1
    <your boot device>/profiles/3-lazy/usr/local/bin/defaulthtmlviewer1

Have fun!

Regards,

gjuhasz
Back to top
View user's profile Send private message 
gjuhasz


Joined: 29 Sep 2008
Posts: 396

PostPosted: Sat 16 Mar 2019, 13:33    Post subject: Firefox 65 (Stable) and 67 (Nightly)  

Dear Puli users,

I uploaded the latest stable Firefox package (firefox_65-amd64hu.pet) to

https://drive.google.com/drive/folders/1saZz9KmygvXKmB1XtCSB-UYHGs3mfNSi

HU version. For other languages, download the appropriate localized .tar.gz (notice that https://www.mozilla.org opens <yourlocale> page automatically) then replace the /opt/firefox folder in my pet file with the downloaded content.

You can (smart)load and use it in Puli 7 and maybe in other Xenial64 based Puppy Linux flavors. Runs as spot with sound, Flash Player supported.

There is a March 15 nightly package (firefox_67-amd64hu.pet) next to it. Same settings, no issues found. You can update it or get another language as written above.

Have fun!

Regards,

gjuhasz
Back to top
View user's profile Send private message 
gjuhasz


Joined: 29 Sep 2008
Posts: 396

PostPosted: Tue 23 Apr 2019, 13:52    Post subject: Kernel 4.19.23 with nvidia driver for Puli  

Dear Puli users,

I tested Puli with k4.19.23.

The related files (vmlinuz, zdrv_puli7.0.sfs, nvidia-340_K4.19.23_x86_64.pet) can be downloaded from here.

Providing that

1. The original (4.9.58 kernel) /vmlinuz and /zdrv_puli7.0.sfs files on the boot pendrive are replaced with the new (k4.19.23) ones,
2. This nvidia pet file exists in the /packages folder on the pendrive,
3. The /env-<macaddress> folder on the pendrive contains a
    nvidia-340_K4.19.23
line, you can smartload and activate this nvidia driver simply by selecting the
    puli 7.0 (proprietary nvidia video driver)
menu item at boot time (which is the default choice).


Have fun!

Regards,

gjuhasz
Back to top
View user's profile Send private message 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15546
Location: Paradox Realm

PostPosted: Tue 23 Apr 2019, 19:21    Post subject:  

Yeah Pulli

Bravo gjuhasz Very Happy

I am thinking of training a fish in a wet suit to physically remove the Ethernet cable - however replacing it again is not easy for a sardine Laughing

Meanwhile looking for potential candidates for Puppy 9

Pulli if it worked on a raspberry pi would fulfill at least two criteria ...

... anyways thanks for keeping us safe from FUD, NSA and SPECTRE Cool

_________________
Puppy on Raspberry Pi Release Candidate Cool Puppy Links Page http://www.smokey01.com/bruceb/puppy.html Very Happy
Back to top
View user's profile Send private message Visit poster's website 
gjuhasz


Joined: 29 Sep 2008
Posts: 396

PostPosted: Thu 25 Apr 2019, 14:18    Post subject: Fish training - proposed curriculum  

Lobster wrote:
I am thinking of training a fish in a wet suit to physically remove the Ethernet cable - however replacing it again is not easy for a sardine Laughing


Dear Lobster,

I think it is irrelevant for fish training that they physically remove the internet cable or detach/eject the storage media from the machine.

Unfortunately, poor sardines can neither handle the scissors nor the screwdriver, therefore only the command line solution can be taken into account.
Thus, since the (most secure) physical action is the requirement, here I recommend including

Code:
diskdrop


instead of "ifconfig eth0 down" to the curriculum.

If so, at the end of the successful exam, hard disks become detached (spun down, heads parked).

Then, what next? I agree that spin-up of hard disks is difficult even for a sardine... Smile

But, why not? I can imagine that a fish accidentally types

Code:
diskrise


then hits Enter ... Laughing

I admit, there is only one thing remains for me to understand: the magic functionality of the wet suit… Laughing

Have fun!

Regards,

gjuhasz
Back to top
View user's profile Send private message 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15546
Location: Paradox Realm

PostPosted: Thu 25 Apr 2019, 18:40    Post subject:  

Thanks for the tips @gjuhasz Very Happy

I do have fun. Good advice. Cool

My current pc has no wifi, so I can disconnect the ethernet cable.

Any plans for pulli pi? An arm (raspberry pi) pulli ...

Ah the wet suit. For a sardine it is basically a fish shaped water container. Hope that helps.

We are now on the root to Puppy9
The best small dog money can not buy ...
Pulli security strategy might be an option ... who knows ...

Live Long and Puppy 🐶
(Traditional Vulcan Dorg greeting)

_________________
Puppy on Raspberry Pi Release Candidate Cool Puppy Links Page http://www.smokey01.com/bruceb/puppy.html Very Happy
Back to top
View user's profile Send private message Visit poster's website 
gjuhasz


Joined: 29 Sep 2008
Posts: 396

PostPosted: Tue 21 May 2019, 09:11    Post subject: Support for Ubuntu 14.04 ends April 30  

Dear Puli users,

As you know, Ubuntu 14.04 LTS reached its End of Life (EOL) on April 30. However, extended security maintenance for customers remains in place until Q2 2022. For more information, please follow the link:

https://www.ubuntu.com/about/release-cycle

So, I believe that the last 32-bit Puli (version 6.2) will continue to work in the upcoming years without any significant issues.

In my plans, only the 64 bit Puli 7.x version will be regularly updated in line with the Ubuntu LTS based puppies such as Bionic Beaver, Fury Flamingo Smile etc.

Puli 7.1 is on horizon with interesting new features and some Bionic elements.

Have fun!

Regards,

gjuhasz
Back to top
View user's profile Send private message 
gjuhasz


Joined: 29 Sep 2008
Posts: 396

PostPosted: Thu 18 Jul 2019, 06:26    Post subject: Latest Audacity and some AppImages uploaded
Subject description: Successfully tested with Puli 7
 

Dear Puli users,

I uploaded many AppImages and others such as the 64-bit audacity-2.3.2p.sfs to this folder:

https://drive.google.com/drive/folders/1saZz9KmygvXKmB1XtCSB-UYHGs3mfNSi

All tested with Puli 7. They probably run with some 64-bit Xenial based puplets, too.


Have fun!

Regards,

gjuhasz
Back to top
View user's profile Send private message 
gjuhasz


Joined: 29 Sep 2008
Posts: 396

PostPosted: Mon 12 Aug 2019, 11:46    Post subject: Announcement: Puli 7.1  

Dear Puli users,


I am proud to announce the 64-bit Puli 7.1.

The main files are available at http://smokey01.com/gjuhasz/Puli-7.1_Aug2019/.

Installation instructions and detailed description of the new version can be found at http://smokey01.com/gjuhasz/readme-701.html and on the first page of this forum thread.

External 32/64 bit packages are regularly updated in the shared folder structure at

https://drive.google.com/drive/folders/1GTuMK6jq3BCcZhs6sZ2cDUFmGU8pYtlN and at
https://sourceforge.net/projects/puppyszoftver/files/Puli/.

Changes include new features such as AppImage support, enhanced sandboxing, newer modules, updated references and bug fixes, too. More details will be available soon.
You can find the development in the features by browsing the readme files of Puli 7.1 and the earlier Pulis at http://www.smokey01.com/gjuhasz.


Have fun!

Regards,

gjuhasz
Back to top
View user's profile Send private message 
gjuhasz


Joined: 29 Sep 2008
Posts: 396

PostPosted: Tue 20 Aug 2019, 09:01    Post subject: Re: Announcement: Puli 7.1  

gjuhasz wrote:

More details will be available soon.


Please find the main changes as follows:

Improvements:

* Support AppImage format apps (icon pops up on the desk)
* Improve compatibility with the "factory default" version of external apps (.deb, .rpm)
* Firejail support extension (auto-run Firefox in sandbox)
* Nvidia driver support (option to block nouveau at boot time)
* Update/remove obsolete modules
* Improve "Lazy" security profile
* Bugs fixed

Others:

* Bugs fixed
* Puli specific Firefox 68 (stable) and 70 (nightly) versions created
* Uploaded many tested apps to https://sourceforge.net/projects/puppyszoftver/files/Puli/.

Have a fun!

Regards

gjuhasz
Back to top
View user's profile Send private message 
gjuhasz


Joined: 29 Sep 2008
Posts: 396

PostPosted: Sun 01 Sep 2019, 15:51    Post subject: Runtime parameters from menu  

I made a little AddParams.pet package that allows adding runtime parameters to the executable files (application_x-executable) and shared libs (application_x-sharedlib) from their right-click menu.

It can support us when special parameters are needed for running AppImages and/or in the sandboxed environment of firejail.

The prefix and the postfix can be defined separately or can remain blank.

A simple example:

1. Right-click on /usr/bin/links2 and select Apply Runtime Parameters in the menu
2. Enter run-as-spot as Prefix then click OK.
3. Enter -g murga-linux.com/puppy as Postfix, then click OK.
4. The selected app (Links) starts showing our forum page.

For each runs, the latest prefix and postfix are displayed. The edited ones are stored except if you click Cancel. The latest parameters are available in the subfolders of /root/.config/adrtprs/ until shutdown/reboot.

You can play with other executables, add firejail parameters (requires installed firejail, of course). See the attached pictures.

No special message appears in case of runtime errors. However. this info is accessible in /tmp/adrtprs until the next run of AddParams.

Uploaded to:

https://sourceforge.net/projects/puppyszoftver/files/Puli/Puli-64bit/packages/

Tested with Puli 7.1 but probably works with many other puplets, too.


Have a fun!

Regards,

gjuhasz
Prefix.jpg
 Description   
 Filesize   13.3 KB
 Viewed   384 Time(s)

Prefix.jpg

Postfix.jpg
 Description   
 Filesize   12.61 KB
 Viewed   384 Time(s)

Postfix.jpg

Back to top
View user's profile Send private message 
gjuhasz


Joined: 29 Sep 2008
Posts: 396

PostPosted: Thu 05 Sep 2019, 13:18    Post subject: Puli 32-bit packages  

Dear Puli users,

I uploaded many 32-bit packages to

https://sourceforge.net/projects/puppyszoftver/files/Puli/Puli-32bit/packages/

Tested with Puli 6.2.0

Have fun!

Regards,

gjuhasz
Back to top
View user's profile Send private message 
gjuhasz


Joined: 29 Sep 2008
Posts: 396

PostPosted: Mon 09 Sep 2019, 05:29    Post subject: Updated Puli 64-bit packages
Subject description: Soundpack editors
 

Dear Puli users,

Many of us like playing with midi instruments and need a good soundpack editor.

I pulified a couple of them:
    * Downloaded polyphone 1.8 from Ubuntu Xenial64 launchpad and added some qt5 libraries.
    * Downloaded swami 2.0 (see http://www.swamiproject.org/) from Launchpad and added the missing libraries.
See polyphone_1.8_amd64p.pet and swami_2.0-amd64p.pet at

https://sourceforge.net/projects/puppyszoftver/files/Puli/Puli-64bit/packages/

Tested with Puli 7.1 - note that they use the built-in apulse instead of pulseaudio.


Have fun!

Regards,

gjuhasz
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 17 of 18 [262 Posts]   Goto page: Previous 1, 2, 3, ..., 15, 16, 17, 18 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1064s ][ Queries: 12 (0.0467s) ][ GZIP on ]