Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 04 Mar 2015, 09:10
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Security/Privacy
Change spot's privileges
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
s243a

Joined: 02 Sep 2014
Posts: 37

PostPosted: Sun 28 Dec 2014, 01:20    Post_subject:  Change spot's privileges  

How do I change the user privileges of spot? For some reason when I change users to spot I can't see directors. "cd" won't work. "ls" won't show directories. I am using the version of puppylinux called precise.


**Probably non-relavant note:
I have set up precise on other computers and haven't had this problem. I am having the problem on a 64 bit computer. The computers that I ran spot successfully was 32 bits.
Back to top
View user's profile Send_private_message 
s243a

Joined: 02 Sep 2014
Posts: 37

PostPosted: Tue 30 Dec 2014, 23:04    Post_subject:  

I may have fixed the problem. I'll test it tommorow. I noticed by typing "whoami" that "su spot" wasn't changing the user to spot. I saw from this thread:
http://unix.stackexchange.com/questions/39314/su-does-not-change-user-but-does-not-respond-with-an-error-either

that the problem may be caused by the etc/passwd file. I compared this file with the original one on the cd and saw the last two lines missing. Furthermore for some reason the last line I had ended with an apostrophy. I deleted the apstrophy and added the missing two lines. I will test it tommorow to see if it is working, since tommorow I'll be back somewhere with wi-fi.
Back to top
View user's profile Send_private_message 
s243a

Joined: 02 Sep 2014
Posts: 37

PostPosted: Tue 30 Dec 2014, 23:09    Post_subject:  

cd is still not working as spot bu "su" seems to change users now.
Back to top
View user's profile Send_private_message 
s243a

Joined: 02 Sep 2014
Posts: 37

PostPosted: Tue 30 Dec 2014, 23:40    Post_subject:  

This is wierd. If I use the -P option then cd works for spot as it should but without the -P option, I'm told the item is not a directory. This makes no sence because I see no symbolic links in the spot directory.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Security/Privacy
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0397s ][ Queries: 11 (0.0043s) ][ GZIP on ]