Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 27 Aug 2016, 07:56
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Documents
LyX – The Document Processor
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [16 Posts]   Goto page: 1, 2 Next
Author Message
ProfeRonald

Joined: 28 Dec 2014
Posts: 5

PostPosted: Mon 29 Dec 2014, 14:42    Post subject:  LyX – The Document Processor
Subject description: Installer Package - PET - Version 2.1.2
 



LyX is a document processor that encourages an approach to writing based on the structure of your documents (WYSIWYM) and not simply their appearance (WYSIWYG)

More about Lyx: http://en.wikipedia.org/wiki/LyX

Lyx official page: http://lyx.org]http://lyx.org

This version has been tested on Puppy Tahrpup 6.0

Download: http://ge.tt/api/1/files/3Mhpve72/0/blob?download


Enjoy!
Back to top
View user's profile Send private message 
Pelo


Joined: 10 Sep 2011
Posts: 9068
Location: Mer méditerrannée (1 kms°)

PostPosted: Tue 30 Dec 2014, 23:13    Post subject: Lyx dowloaded for test (15.3MB)
Subject description: precise 5.7.1
 

AbiWord
Apache OpenOffice Writer
Document.Editor
Calligra Words
GNU TeXmacs
Groff
JWPce is a Japan J'accepteese word processor, designed primarily for the English speaker who is reading or writing in Japanese.
KWord
LyX
LibreOffice Writer
Ted

# lyx
lyx: error while loading shared libraries: libaspell.so.15: cannot open shared object file: No such file or directory
#
[/b]
libaspell pet click the blue, pleease

python missing undefined symbol: _ZN9QListData11detach_growEPii

_________________
Puppy Bikers : Born to be Wild !
Back to top
View user's profile Send private message Yahoo Messenger 
ProfeRonald

Joined: 28 Dec 2014
Posts: 5

PostPosted: Wed 31 Dec 2014, 00:38    Post subject:  

"This version has been tested on Puppy Tahrpup 6.0"

You need qt4 and qt4-devel packages:

QT4: http://www.smokey01.com/pemasu/Pets_Qt4/qt4-4.8.0.pet, http://www.smokey01.com/pemasu/Pets_Qt4/qt4_DEV-4.8.0.pet
Back to top
View user's profile Send private message 
Pelo


Joined: 10 Sep 2011
Posts: 9068
Location: Mer méditerrannée (1 kms°)

PostPosted: Wed 31 Dec 2014, 01:14    Post subject: QT4 being loaded from my tool case
Subject description: Precise will run Lyx
 

Precise will run Lyx . Why you prefer Lyx to other word processors would be useful argument to install it.
QT4 25MB downloaded.

_________________
Puppy Bikers : Born to be Wild !
Back to top
View user's profile Send private message Yahoo Messenger 
ProfeRonald

Joined: 28 Dec 2014
Posts: 5

PostPosted: Wed 31 Dec 2014, 02:13    Post subject:  

Back to top
View user's profile Send private message 
LazY Puppy


Joined: 21 Nov 2014
Posts: 1209
Location: Germany

PostPosted: Wed 31 Dec 2014, 06:35    Post subject:  

ProfeRonald wrote:
Lyx es más adecuado para documentos científicos.

Read this:
http://www.troubleshooters.com/linux/lyx/bestandworst.htm

Smile

Just fixed the messed up URL tag.

_________________
RSH

T.O.P.L.E.S.S. - the Multi-Language Puppy Linux Wrapper.

Zivilcourage bringt nichts als Ärger ein!
Back to top
View user's profile Send private message 
ProfeRonald

Joined: 28 Dec 2014
Posts: 5

PostPosted: Wed 31 Dec 2014, 15:04    Post subject:  

Thanks, yeah...Lyx is better suited for scientific documents. Very Happy
Back to top
View user's profile Send private message 
totolanio

Joined: 03 Jan 2015
Posts: 187

PostPosted: Fri 18 Sep 2015, 14:53    Post subject:  

It keeps saying missing classes (.cls)

what to do ?

_________________
Main puppy used : LxPup tahr.
Multiple package installer/remover.
Back to top
View user's profile Send private message 
totolanio

Joined: 03 Jan 2015
Posts: 187

PostPosted: Wed 14 Oct 2015, 12:23    Post subject:  

On another linux distribution based on ubuntu 14.04, I installed Lyx and had the same problem, so I installed TexLive and it solved the problem.
In the package manager, there are tons of different packages called texlive, so I don't know which one to download. I only want to write guides, tutorials and texts for now, so n o need for maths nor science etc
If someone has an idea.

_________________
Main puppy used : LxPup tahr.
Multiple package installer/remover.
Back to top
View user's profile Send private message 
uio

Joined: 31 Aug 2015
Posts: 77

PostPosted: Sat 17 Oct 2015, 12:35    Post subject:  

Hi totolanio,

I too am looking for a solution to LaTeX problems... here are some threads describing my problem and another that used to have the package I believe we are looking for... (I'm sure there are others) :

http://murga-linux.com/puppy/viewtopic.php?t=50243
http://murga-linux.com/puppy/viewtopic.php?t=101259

Let me know if you find anything, or hopefully emil will repost his .sfs....

:uio
Back to top
View user's profile Send private message 
uio

Joined: 31 Aug 2015
Posts: 77

PostPosted: Sat 17 Oct 2015, 13:57    Post subject: this thread might help...  

Hi totolanio,

I've not yet tried it, but I think (hope) that this thread might have some useful information on LaTeX :

http://www.murga-linux.com/puppy/viewtopic.php?t=30577&start=30

::uio
Back to top
View user's profile Send private message 
totolanio

Joined: 03 Jan 2015
Posts: 187

PostPosted: Sat 24 Oct 2015, 18:56    Post subject:  

I only use Lyx, I don't even know how to use latex lol

Tell me if you find something else. But there is a hint for you, you can download some related latex stuff in the package manager from Ubuntu repositories because you're on Tahr Pup.

There is texlive for example but it's very huge. Didn't solve my problem yet. (Didn't install texlive_full)

_________________
Main puppy used : LxPup tahr.
Multiple package installer/remover.
Back to top
View user's profile Send private message 
Pelo


Joined: 10 Sep 2011
Posts: 9068
Location: Mer méditerrannée (1 kms°)

PostPosted: Fri 06 Nov 2015, 07:34    Post subject: Please explain a little bit what is LyX,  

Would you buy something ignoring what it will be usefull to ?
Please explain a little bit what is LyX,
Intallation will depend on What Lyx will bring as application

_________________
Puppy Bikers : Born to be Wild !
Back to top
View user's profile Send private message Yahoo Messenger 
Hotdog


Joined: 29 Sep 2011
Posts: 146
Location: Georgia USA

PostPosted: Thu 12 Nov 2015, 21:45    Post subject: LyX usefulness  

Pelo,

LyX is a graphical interface for processing text into proper page layout. You choose what the output will be used for, an article, thesis, a scientific journal, magazine or even a book. You only have to concentrate on the content and LyX with the aid of typesetting software (LaTeX and TeX) in the background, will align and style your text into the appropriate layout. It does a great job on math formulas. Universities, symposiums and technical journals require the use of it in submissions to them.

It does wonders on other writing, too. There are 100's of packages (we might call them templates) for just about every kind of writing that you can imagine. And if you are willing to learn the core LaTeX language you can make your own packages and styles.

_________________
Puppy 5.2.8.7, Full Install
Back to top
View user's profile Send private message 
superchook

Joined: 13 Mar 2006
Posts: 78
Location: Sydney, Australia

PostPosted: Wed 18 Nov 2015, 07:34    Post subject: LyX – The Document Processor  

Earlier today I posted in another thread (Tips for publishing tools wanted... Things for Puppy that is ) the following:

Does anyone on the list have any experience using mom?

http://www.schaffter.ca/mom/

The proponents of mom and groff acknowledge that it can not do everything that TeX can, but argue that it can cover a large subset with a much smaller application.

If mom + groff can produce the results required then it might be worth investigating the size of the application together with its dependencies.

Puppy already includes groff but I do not know if it is the latest version or whether the mom macro package is provided. I note that Debian splits groff into groff-base and groff. I do not know how FatDog does things nor Slacko.

This post is probably of relevance on another thread discussing LyX.

cheers,
Ken
(This is that other thread)
Since writing the above I have been trying without success to see if Puppy does indeed have groff installed. I have tried tahr6.0.3, and slacko 6.3.0 both the 64 and 32 bit versions. Typing groff --help on a command line returns a message that groff cannot be found and typing which groff returns nothing, Typing groff in the search box in the Puppy Package manager indicates that groff_1.22.2-5 is installed.
I am at a bit of a loss as to what to try next. Any suggestions?
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 2 [16 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Documents
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1311s ][ Queries: 11 (0.0050s) ][ GZIP on ]