Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 23 Jul 2018, 11:51
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Slimjet web browser
Post new topic   Reply to topic View previous topic :: View next topic
Page 9 of 11 [157 Posts]   Goto page: Previous 1, 2, 3, ..., 7, 8, 9, 10, 11 Next
Author Message
Mike Walsh


Joined: 28 Jun 2014
Posts: 3925
Location: King's Lynn, UK.

PostPosted: Sun 16 Jul 2017, 09:08    Post subject:  

Hi, Oscar.

Yes, that works nicely. I now have my remote copy of SlimJet (currently 15.0.2.0) running in all Pups in the kennel.

I just did what Phil suggested. I have the script open in one window, and my extracted tarball of 'Slimmie' open in another.. Drag the binary across, 'drop' it on the script. All done.

And the same 'trick' works for Iron, too! (Which is hardly surprising...)

I think you're right about libudev. Initially, I'd tried with this still in place a few days ago, before your last post, and.....it didn't want to know. So I've removed it, after performing the BBE-script trick; runs a treat now. Thanks for the tip.

(And there is a LOT less crud in the terminal.)

Under normal circumstances, I'd use your 32-bit packages anyway.....but with having such a convoluted set-up, running multiple sym-linked apps from a remote partition, it really is simpler (for me) to just extract the downloaded tarball, swap 'em over, then perform the mods 'in situ'. But,again:-

.....thanks for the tip!

(davids45 has got a lot to answer for; but his method for running sym-linked apps remotely is a life saver for me. Running the same set of apps in at least 10 different Pups, it'd just be crazy to install every one of 'em 10 times..!)

Cheers.


Mike. Wink

_________________
MY PUPPY PACKAGES | 'Thanks' are always appreciated!
--------------------------------------

Back to top
View user's profile Send private message Visit poster's website 
Marv


Joined: 04 May 2005
Posts: 1061
Location: SW Wisconsin

PostPosted: Fri 21 Jul 2017, 13:42    Post subject:  

Version 15.0.3.0 (from OscarTalks SFS) running well in LxPupSx 17.07.24, LxPupXenial (XenialPup 7.0.8.1 based), and X-Slacko 4.2. SFS in the Grub4Dos boot directory, shared by all, and the profile in my EXT2 data partition with symlinks in the various pups. No cruft at all in terminal!

Edit: Updated to 15.0.4.0 using OscarTalks i686 SFS on my all intel i5 laptop (Fujitsu S761) running LxPupSc 17.08.21. No issues noted. Also checked in X-Slacko 4.2, X-Tahr-2.0 and LxPupXenial 17.06.1 on that laptop. Starts and runs fine in all.

Edit: Now updated (08/20/2017) to Version 15.1.0.0 on the S761 laptop per above but now running LxPupSc 17.08.23. Also 15.0.4.0 i686 SFS is now running full time on an intel Bay Trail (J1900 CPU) desktop box running X-Slacko 4.3. No issues noted on either.

Thanks,

_________________
Pups currently in kennel Very Happy LxPupSc and X-slacko-4.4 for my users; LxPupSc, LxPupSc64, and LxPupBB for me. All good pups indeed, and all running savefiles for look'n'feel only. Browsers, etc. solely from SFS. Now tazpup for puzzles Smile
Back to top
View user's profile Send private message 
Marv


Joined: 04 May 2005
Posts: 1061
Location: SW Wisconsin

PostPosted: Mon 16 Oct 2017, 21:22    Post subject:  

Bump: 10/16/2017. Now running Version 15.1.5.0 on the SS761 laptop, both in ZestyPup 17.10.13 and in LxPupSc 17.10.22. Runs well in both, using it as the default browser across the board. Twas an edit but I wanted you to know someone appreciates your SFS over time. Download link here

Thanks again.. and again,

_________________
Pups currently in kennel Very Happy LxPupSc and X-slacko-4.4 for my users; LxPupSc, LxPupSc64, and LxPupBB for me. All good pups indeed, and all running savefiles for look'n'feel only. Browsers, etc. solely from SFS. Now tazpup for puzzles Smile
Back to top
View user's profile Send private message 
roadkill13

Joined: 10 Aug 2011
Posts: 117
Location: United States

PostPosted: Mon 23 Oct 2017, 00:45    Post subject:  

@marv

Quote:
Bump: 10/16/2017. Now running Version 15.1.5.0 on the SS761 laptop, both in ZestyPup 17.10.13 and in LxPupSc 17.10.22. Runs well in both, using it as the default browser across the board. Twas an edit but I wanted you to know someone appreciates your SFS over time. Download link here

Thanks again.. and again,


Thanks for the heads up.

@OscarTalks

Thank you, Thank you, Thank you...

Running quite well in Musher0's xenial 7.06 derivative.
Back to top
View user's profile Send private message Yahoo Messenger 
greengeek


Joined: 20 Jul 2010
Posts: 5094
Location: Republic of Novo Zelande

PostPosted: Sat 23 Dec 2017, 15:10    Post subject:  

Does anyone have a version of Slimjet that runs on Slacko 5.6 (slack 14.0 compatible) that is capable of accessing Youtube? I have just tried several of OscarTalks versions (that I thought were working on youtube previously) but they all tell me I have no compatible video formats and offer to tell me more about html5.

Are some versions of Slimjet HTML5 compatible or am I somehow setting up wrong?
Back to top
View user's profile Send private message 
OscarTalks


Joined: 05 Feb 2012
Posts: 1782
Location: London, England

PostPosted: Sat 23 Dec 2017, 22:04    Post subject:  

I have Slacko 5.7 on one of my machines here and Slimjet 14.0.16.0 is working and playing YouTube videos OK. You might need to uncheck the option to force the use of flashplayer on YouTube in the settings and possibly restart Slimjet afterwards.
_________________
Oscar in England

Back to top
View user's profile Send private message 
Sylvander

Joined: 15 Dec 2008
Posts: 4352
Location: West Lothian, Scotland, UK

PostPosted: Sat 23 Dec 2017, 22:28    Post subject:  

OscarTalks wrote:
I have Slacko 5.7 on one of my machines here and Slimjet 14.0.16.0 is working and playing YouTube videos OK.

I too run Slacko 5.7.
Could you post a link to a Slimjet 14.0.16.0 SFS?
Back to top
View user's profile Send private message 
greengeek


Joined: 20 Jul 2010
Posts: 5094
Location: Republic of Novo Zelande

PostPosted: Sun 24 Dec 2017, 02:24    Post subject:  

Sylvander wrote:
I too run Slacko 5.7.
Could you post a link to a Slimjet 14.0.16.0 SFS?
Have a look at this link from Oscars post on previous page:
https://yadi.sk/d/fd8rBM0WoF9sB?force_show=1
Back to top
View user's profile Send private message 
greengeek


Joined: 20 Jul 2010
Posts: 5094
Location: Republic of Novo Zelande

PostPosted: Sun 24 Dec 2017, 02:29    Post subject:  

OscarTalks wrote:
I have Slacko 5.7 on one of my machines here and Slimjet 14.0.16.0 is working and playing YouTube videos OK. You might need to uncheck the option to force the use of flashplayer on YouTube in the settings and possibly restart Slimjet afterwards.
Many thanks Oscar - that did the trick. cheers!
Back to top
View user's profile Send private message 
Sylvander

Joined: 15 Dec 2008
Posts: 4352
Location: West Lothian, Scotland, UK

PostPosted: Sun 24 Dec 2017, 03:54    Post subject:  

Slimjet 14.0.16.0 sfs is now available and functioning within my Slacko-5.7.0-pae.
Is this a version of Chrome?
It's a pity that Google gathers info on the users' browsing.
If they were only being helpful I wouldn't mind so much, but...
I did some configuring, but not exactly sure of what I'm doing.

Ahh, youtube videos won't play.
Tried: "uncheck the option to force the use of flashplayer on YouTube in the settings", but I get a forced Google sign-in box.
Must this be completed before settings can be configured?
Back to top
View user's profile Send private message 
OscarTalks


Joined: 05 Feb 2012
Posts: 1782
Location: London, England

PostPosted: Sun 24 Dec 2017, 10:15    Post subject:  

As I understand it, Slimjet is a derivative of the Chromium open source project.
There are a number of these, including Chrome which is Google's fully branded derivative.

I am able to watch YouTube videos and was never presented with anything requiring me to sign in to Google. I believe that YouTube may not work with flash player at all nowadays. It is HTML5 only I think. The tickbox for forcing the use of flash needs to be unchecked and it has been removed from later Slimjet versions as it no longer works at all. I sometimes update the pepper flash version in those packages. Users can do this manually too if they find a need to. A lot of media handling has moved away from flash now though so it is needed much less than before.

_________________
Oscar in England

Back to top
View user's profile Send private message 
Sailor Enceladus

Joined: 22 Feb 2016
Posts: 1530

PostPosted: Sun 24 Dec 2017, 15:16    Post subject:  

I too noticed that I had to uncheck the "Force flashplayer" option in Slimjet 14.0.16 settings to play youtube videos (I don't have flash installed). It was quite easy to fix once I found the option, but a strange option to have checked by default I think, I would think the complete opposite would make more sense in 2017 (force youtube to use html5 even if Flash is installed).
Back to top
View user's profile Send private message 
Sylvander

Joined: 15 Dec 2008
Posts: 4352
Location: West Lothian, Scotland, UK

PostPosted: Sun 24 Dec 2017, 22:23    Post subject:  

Sailor Enceladus wrote:
It was quite easy to fix once I found the option...

Where is it?
What steps to find it?
Back to top
View user's profile Send private message 
OscarTalks


Joined: 05 Feb 2012
Posts: 1782
Location: London, England

PostPosted: Sun 24 Dec 2017, 23:02    Post subject:  

Open the "Settings" page
Scroll down to the "Misc" section near the bottom
Remove the tick from the "force flash player" option
Close and restart Slimjet
forceflash.jpg
 Description   Remove the tick from the option to force flash player
 Filesize   66.7 KB
 Viewed   151 Time(s)

forceflash.jpg


_________________
Oscar in England

Back to top
View user's profile Send private message 
sleeper48

Joined: 24 Dec 2017
Posts: 14

PostPosted: Sun 24 Dec 2017, 23:31    Post subject:  

OscarTalks wrote:
I sometimes update the pepper flash version in those packages. Users can do this manually too if they find a need to.


How do I manually update the slimjet flash? Can't seem to find libpepflashplayer.so anywhere. I'm on slacko puppy 5.6 with slimjet 15.1.6.0.

Last edited by sleeper48 on Mon 25 Dec 2017, 02:42; edited 4 times in total
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 9 of 11 [157 Posts]   Goto page: Previous 1, 2, 3, ..., 7, 8, 9, 10, 11 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0755s ][ Queries: 14 (0.0207s) ][ GZIP on ]