Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 20 May 2018, 21:49
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » REQUESTS
What's this .pet package ? pacman-2.9.8.pet
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [7 Posts]  
Author Message
dog_dancer

Joined: 16 Feb 2015
Posts: 17

PostPosted: Mon 16 Feb 2015, 15:18    Post subject:  What's this .pet package ? pacman-2.9.8.pet
Subject description: I would like can have the pacman package manager and install software
 

whats up

I was jus lookin for the pac-man game lol, but i found this pet and I installed it and I realize it wasnt the game , I think is the archlinux package manager ''pacman'' my friend uses archlinux and it is cool, so I would like to can have Pacman and Puppy Package manager together in Puppy Linux, it is possible?
well first at all am not sure yet this is what i think it is...

By the way , I also found the pacman game .pet package so if somebody need it, just tell me
pacman-2.9.8.pet
Description 
pet

 Download 
Filename  pacman-2.9.8.pet 
Filesize  89.68 KB 
Downloaded  196 Time(s) 
Back to top
View user's profile Send private message 
dog_dancer

Joined: 16 Feb 2015
Posts: 17

PostPosted: Tue 17 Feb 2015, 12:30    Post subject: can somebody help please?  

Anyone there can please tell tell me what this .pet is for?

Thanks
Back to top
View user's profile Send private message 
cimarron


Joined: 30 May 2013
Posts: 293

PostPosted: Tue 17 Feb 2015, 12:45    Post subject:  

There have been a few puppy derivatives built with Arch linux packages, and at least one used the pacman package manager. I'd guess it's a .pet for that. It would only useful for a puppy using Arch linux packages.
Back to top
View user's profile Send private message 
dog_dancer

Joined: 16 Feb 2015
Posts: 17

PostPosted: Tue 17 Feb 2015, 14:11    Post subject: Thanks for reply  

Thanks for reply sir,

So it is possible install arch linux package after installing this pet?

I type pacman in the console and it seems it works but then I have try to install some packages but I did not get it, I dont know if Maybe i dont type the correct commands or somethin
Back to top
View user's profile Send private message 
Keisha

Joined: 18 Nov 2014
Posts: 465

PostPosted: Tue 17 Feb 2015, 16:28    Post subject: Re: Thanks for reply  

dog_dancer wrote:
...So it is possible install arch linux package after installing this pet?...

No. This .pet will work correctly only on a Pup which was built using the Arch recipes for init and configuration files. The old ArchPup could use it, but there is no contemporary version of Puppy built on the Arch recipe.

Theoretically you could make an Arch-based Puppy yourself, using Woof-CE. But no one will do it for you.

If you want an Arch-based liveCD, I suggest you check out simargl's modern successor to ArchPup, alphaOS,
http://sourceforge.net/projects/alphaos/

_________________
“A wise man can learn more from a foolish question than a fool can learn from a wise answer.” --Bruce Lee
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 10422
Location: Charleston S.C. USA

PostPosted: Tue 17 Feb 2015, 16:39    Post subject: Re: Thanks for reply  

dog_dancer wrote:
Thanks for reply sir,

So it is possible install arch linux package after installing this pet?


Unless you are using Archpup, not a good idea to try using Arch Linux packages.

They will most likely require dependency programs that are not in Puppy and the way they are compiled may not even work.

The Puppy Package Manager is setup to handle the program packages that will work on Puppy.
That is the whole purpose of a package manager.
Program packages have to be compiled for the Linux operating system they will be specifically for.
Puppy uses pet packages.

Now, some versions of Puppy are able to use program packages from other Linux operating systems, however they usually require additional dependency programs/files to make them work in Puppy.

Example:
Tahrpup 6.0.2 CE can use packages from Ubuntu Linux, but not any Ubuntu Linux. It has to be stuff compiled for Ubuntu-trusty.
Even so, most of the Ubuntu-trusty packages will also require a lot of added dependency program/files to work in Tahrpup.
Tahrpups Puppy Package Manager knows how to handle this.

Even Puppy pet packages do not work on all versions of Puppy.
A pet package made several years ago will not have the setup for the way Puppy has changed and evolved.

Use the Puppy Package Manager (PPM).

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
dog_dancer

Joined: 16 Feb 2015
Posts: 17

PostPosted: Wed 18 Feb 2015, 03:58    Post subject:  

thank you very much , is just that would have been cool for me make this works even would be just for few packages that does not need non-compatible dependecies in puppy 528.

am gonna check those puppy arch, it seems curious.

those arch puppies are compatible with puppy linux 528 packages?
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [7 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » REQUESTS
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0462s ][ Queries: 12 (0.0156s) ][ GZIP on ]