Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 27 Sep 2016, 05:05
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Usuarios de habla Hispana
livestreamer PET?
Moderators: rarsa
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [11 Posts]  
Author Message
clau

Joined: 10 Apr 2011
Posts: 13

PostPosted: Wed 04 Mar 2015, 13:39    Post subject:  livestreamer PET?  

Alguien se decide a hacer una PET.....
https://github.com/chrippa/livestreamer/releases

Gracias!
Back to top
View user's profile Send private message 
nilsonmorales


Joined: 15 Apr 2011
Posts: 861
Location: El Salvador

PostPosted: Thu 05 Mar 2015, 02:17    Post subject:  

livestreamer-1.12.0.pet MD5SUM dc9dd54d6c35e4d96c28afab8e677f59 325KB
Compilado en tahrpup, posiblemente funcione en derivados debian/ubuntu de Puppy
Compilación:
Code:
python setup.py install --root=/tmp/livestreamer-1.12.0
dir2pet /tmp/livestreamer-1.12.0

Forma de uso en Puppy:
Code:
livestreamer --yes-run-as-root twitch.tv/day9tv best

Librerías adicionales:
ca-certificates_20130906ubuntu2
debconf_1.5.51ubuntu2
python-chardet_2.0.1
python-six_1.5.2-1
python-urllib3_1.7.1
python-request_2.2.1-1
python-singledispatch_3.4.0.2-1
Es necesario hacer mas pruebas y leer documentación, la verdad no se como funciona.
Mi conexion a internet es muy lenta solo pude hacerlo funcionar con esto:
Code:
livestreamer --yes-run-as-root http://www.youtube.com/watch?v=U4Pw3ofFWgs audio_mp4

Saludos.
Editado: Olvidé mencionar que tambien instalé futures-2.2.0, algo de python
Code:
wget -c https://pypi.python.org/packages/source/f/futures/futures 2.2.0.tar.gz#md5=310e446de8609ddb59d0886e35edb534
tar xvzf futures-2.2.0.tar.gz
cd futures-2.2.0
python setup.py install

Son necesarios los devx de la version para compilar en Puppy.

_________________
My blog | | Github


Back to top
View user's profile Send private message 
clau

Joined: 10 Apr 2011
Posts: 13

PostPosted: Thu 05 Mar 2015, 15:30    Post subject:  

Muchas gracias Nilson, voy a probarlo. Este es un ejemplo mas de la gran comunidad de Puppy Linux. Very Happy
Back to top
View user's profile Send private message 
bh56

Joined: 07 Apr 2009
Posts: 53

PostPosted: Sat 13 Aug 2016, 00:07    Post subject: Livestreamer as root  

Hola
Estoy utilizando LxpupXenial .
Cuando entro :
livestreamer --yes-run-as-root
Me sale este error :
livestreamer : Error : no reconocidos argumentos : ----yes-run-as-root
Si entro en :
livestreamer -yes-run-as-root
Yo obtengo:
livestreamer : Error : no reconocidos argumentos : -yes-run-as-root
Estoy utilizando livestreamer 1.12.2-1
No puedo conseguir livestreamer para funcionar
Back to top
View user's profile Send private message 
nilsonmorales


Joined: 15 Apr 2011
Posts: 861
Location: El Salvador

PostPosted: Sat 13 Aug 2016, 01:59    Post subject:  

Estoy en Pupjibaro retro-precise.
Probaste usando pip-7.1.0?
Instala luego en terminal
Code:
pip install -U livestreamer

Quote:
root  Pjibaro  ~  #  pip install -U livestreamer
/usr/local/lib/python2.7/dist-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:90: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning.
InsecurePlatformWarning
You are using pip version 7.1.0, however version 8.1.2 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
/usr/local/lib/python2.7/dist-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:90: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning.
InsecurePlatformWarning
Requirement already up-to-date: livestreamer in /usr/local/lib/python2.7/dist-packages
Collecting futures (from livestreamer)
Downloading futures-3.0.5-py2-none-any.whl
Collecting singledispatch (from livestreamer)
Downloading singledispatch-3.4.0.3-py2.py3-none-any.whl
Collecting requests<3.0,>=1.0 (from livestreamer)
Downloading requests-2.11.0-py2.py3-none-any.whl (514kB)
100% |████████████████████████████████| 516kB 217kB/s
Collecting six (from singledispatch->livestreamer)
Downloading six-1.10.0-py2.py3-none-any.whl
Installing collected packages: futures, six, singledispatch, requests
Found existing installation: futures 3.0.1
Uninstalling futures-3.0.1:
Successfully uninstalled futures-3.0.1
Found existing installation: six 1.9.0
Uninstalling six-1.9.0:
Successfully uninstalled six-1.9.0
Successfully installed futures-3.0.5 requests-2.11.0 singledispatch-3.4.0.3 six-1.10.0

despues probamos en terminal
Code:
livestreamer

Quote:
root  Pjibaro  ~  #  livestreamer
livestreamer is not supposed to be run as root. If you really must you can do it by passing --yes-run-as-root.

Despues probe como cuando hice el primer paquete
Code:
livestreamer --yes-run-as-root http://www.youtube.com/watch?v=U4Pw3ofFWgs audio_mp4

Se me abrio vlc y un audio en ingles de no se que
Quote:
root  Pjibaro  ~  #  livestreamer --yes-run-as-root http://www.youtube.com/watch?v=U4Pw3ofFWgs audio_mp4
[cli][info] Found matching plugin youtube for URL http://www.youtube.com/watch?v=U4Pw3ofFWgs
[cli][info] Available streams: 144p (worst), 240p, 360p (best), audio_mp4, audio_webm
[cli][info] Opening stream: audio_mp4 (http)
[cli][info] Starting player: /usr/bin/vlc
[cli][info] Player closed
[cli][info] Stream ended

Saludos.

_________________
My blog | | Github


Back to top
View user's profile Send private message 
bh56

Joined: 07 Apr 2009
Posts: 53

PostPosted: Sat 13 Aug 2016, 03:42    Post subject: Livestreamer  

Hola,
He instalado livestreamer desde el gestor de paquetes .
He desinstalado y seguido sus instrucciones.
Esto es lo que pasó:

root# pip install -U livestreamer
You are using pip version 7.1.0, however version 8.1.2 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
Collecting livestreamer
Using cached livestreamer-1.12.2.tar.gz
Requirement already up-to-date: futures in /usr/lib/python2.7/dist-packages (from livestreamer)
Requirement already up-to-date: singledispatch in /usr/lib/python2.7/dist-packages (from livestreamer)
Collecting requests<3.0,>=1.0 (from livestreamer)
Downloading requests-2.11.0-py2.py3-none-any.whl (514kB)
100% |████████████████████████████████| 516kB 315kB/s
Requirement already up-to-date: six in /usr/lib/python2.7/dist-packages (from singledispatch->livestreamer)
Installing collected packages: requests, livestreamer
Found existing installation: requests 2.9.1
Uninstalling requests-2.9.1:
Successfully uninstalled requests-2.9.1
Running setup.py install for livestreamer
Successfully installed livestreamer-1.12.2 requests-2.11.0
root# livestreamer --yes-run-as-root
usage: livestreamer [OPTIONS] [URL] [STREAM]
livestreamer: error: unrecognized arguments: ----yes-run-as-root

Sigue siendo el mismo problema.
Gracias por tu ayuda.
Back to top
View user's profile Send private message 
nilsonmorales


Joined: 15 Apr 2011
Posts: 861
Location: El Salvador

PostPosted: Sat 13 Aug 2016, 09:02    Post subject:  

Y si luego de esa línea le agregas lo que le falta, probaste?, osea el software se queja que le faltan argumentos, la URL del stream + el formato o la calidad del video, hace la prueba que yo hice en el post anterior.
_________________
My blog | | Github


Back to top
View user's profile Send private message 
bh56

Joined: 07 Apr 2009
Posts: 53

PostPosted: Sat 13 Aug 2016, 18:21    Post subject: Livestreamer  

Hola,
Intentó:

root# livestreamer yes-run-as-root http://www.youtube.com/watch?v=U4Pw3ofFWgs audio_mp4
usage: livestreamer [OPTIONS] [URL] [STREAM]
livestreamer: error: unrecognized arguments: audio_mp4

También:

Also:
root# livestreamer yes-run-as-root http://www.youtube.com/watch?v=U4Pw3ofFWgs best
usage: livestreamer [OPTIONS] [URL] [STREAM]
livestreamer: error: unrecognized arguments: best

Esto funciona sin embargo :

root# su spot
root$ livestreamer --yes-run-as-root http://www.youtube.com/watch?v=U4Pw3ofFWgs audio_mp4
[cli][info] Found matching plugin youtube for URL http://www.youtube.com/watch?v=U4Pw3ofFWgs
[cli][info] Available streams: 144p (worst), 240p, 360p (best), audio_mp4, audio_webm
[cli][info] Opening stream: audio_mp4 (http)
[cli][info] Starting player: /usr/bin/vlc
[cli][info] Player closed
[cli][info] Stream ended

Estoy utilizando livestreamer como una dependencia del WebDL de:
https://delx.net.au/git/webdl

WebDL tiene una serie de secuencias de comandos .
Uno se llama capturador.
Si funciono el guión wbdl llamado capturador como root me sale:

INFO Downloading: American The Bill Hicks Story.ts
livestreamer is not supposed to be run as root. If you really must you can do it by passing --yes-run-as-root.
ERROR livestreamer exited with error code: 1
Press return to continue...

Si funciono mientras que el spot (mancha Do ) me sale:

Traceback (most recent call last):
File "./grabber.py", line 61, in <module>
main()
File "./grabber.py", line 41, in main
for n in node.get_children():
File "/initrd/mnt/dev_save/webdl/common.py", line 50, in get_children
self.fill_children()
File "/initrd/mnt/dev_save/webdl/iview.py", line 70, in fill_children
info = grab_json(self.url, 3600)
File "/initrd/mnt/dev_save/webdl/common.py", line 150, in grab_json
f = urlopen(url, max_age)
File "/initrd/mnt/dev_save/webdl/common.py", line 102, in urlopen
os.makedirs(CACHE_DIR)
File "/usr/lib/python2.7/os.py", line 157, in makedirs
mkdir(name, mode)
OSError: [Errno 13] Permission denied: '/root/.cache/webdl'

Tengo un archivo en /root/.config/livestreamer/config/.livestreamerrc con la línea:
yes-run-as-root

In /root/.cache/webdl He cambiado los permisos para ¨anyone¨ to view, change or access the file.

Gracias
Debo aprender español
Back to top
View user's profile Send private message 
nilsonmorales


Joined: 15 Apr 2011
Posts: 861
Location: El Salvador

PostPosted: Sun 14 Aug 2016, 22:13    Post subject:  

Baje el webdl y modifique el archivo common.py entre lineas 266-286
Quote:
"livestreamer","--yes-run-as-root",
"-o", filename,
param,
"best",
]
if exec_subprocess(cmd):
return convert_to_mp4(filename)
else:
return False

def download_hls(filename, video_url):
filename = sanify_filename(filename)
video_url = "hlsvariant://" + video_url
logging.info("Downloading: %s", filename)

cmd = [
"livestreamer","--yes-run-as-root",
"-o", filename,
video_url,
"best",
]

Al parecer el error consiste en livestreamer cuando intento usar webdl obtengo estos resultados
Quote:
INFO Downloading: Green Lantern The Animated Series - 1x03 - Razers Edge.flv
[cli][info] Found matching plugin stream for URL hds://http://vod.netshowhd.ninemsn.com.au/z/hds/1622448031001/201605/2611/1622448031001_4906270139001_4906202217001.f4m/manifest.f4m
error: Unable to open URL: http://vod.netshowhd.ninemsn.com.au/z/hds/1622448031001/201605/2611/1622448031001_4906270139001_4906202217001.f4m/manifest.f4m (403 Client Error: Forbidden for url: http://vod.netshowhd.ninemsn.com.au/z/hds/1622448031001/201605/2611/1622448031001_4906270139001_4906202217001.f4m/manifest.f4m)
ERROR livestreamer exited with error code: 1
Press return to continue...

He estado leyendo en github issues pero mi ingles no es tan bueno dejo enlace quizas tu lo arreglas
https://github.com/chrippa/livestreamer/issues?utf8=%E2%9C%93&q=client%20error

_________________
My blog | | Github


Back to top
View user's profile Send private message 
bh56

Joined: 07 Apr 2009
Posts: 53

PostPosted: Mon 15 Aug 2016, 05:28    Post subject: Livestreamer  

Cuando cambio la línea 266 a :
cmd = [
"livestreamer",¨--yes-run-as-root¨,
"-o", filename,
param,
"best",


Yo obtengo:
root# python ./grabber.py
Traceback (most recent call last):
File "./grabber.py", line 3, in <module>
from common import load_root_node, natural_sort
File "/initrd/mnt/dev_save/webdl/common.py", line 267
SyntaxError: Non-ASCII character '\xc2' in file /initrd/mnt/dev_save/webdl/common.py on line 267, but no encoding declared; see http://python.org/dev/peps/pep-0263/ for details


Tengo que he escrito correctamente el comando ?
Gracias de nuevo.
Back to top
View user's profile Send private message 
bh56

Joined: 07 Apr 2009
Posts: 53

PostPosted: Mon 15 Aug 2016, 17:32    Post subject: Livestreamer  

Cambiar el diseño del teclado se fija el código de error .
El programa se ejecuta ahora pero con un código de error diferente.
No creo que va a trabajar .
De nuevo, gracias por tu ayuda.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [11 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Usuarios de habla Hispana
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0640s ][ Queries: 11 (0.0037s) ][ GZIP on ]