Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 06 Jul 2015, 16:05
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Fatdog64-700-save file corrupt on hard reboot-how to fix?
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [3 Posts]  
Author Message
dbabits

Joined: 16 Nov 2007
Posts: 38

PostPosted: Fri 13 Mar 2015, 13:21    Post subject:  Fatdog64-700-save file corrupt on hard reboot-how to fix?
Subject description: save file shows with ! mark - how to fix it?
 

Fatdog64-700.
I had to hard-reboot due to OS freezing on closing of laptop's lid. This is tracked in a separate issue.

Now, upon reboot my save file was skipped, Fatdog booted without it,
and the save file shows with big exclamation mark in file browser, and with all ???? in ls -l output where perms and size would be.

The savefile is on NTFS partition, which is not damaged.
How can I fix it, or at least salvage some information out of it?
Back to top
View user's profile Send private message 
jamesbond

Joined: 26 Feb 2007
Posts: 2465
Location: The Blue Marble

PostPosted: Sat 14 Mar 2015, 12:07    Post subject:  

Try to see if you can open the file by clicking it (or, from terminal, do "filemnt /path/to/your/savefile". If you can open it then hopefully you can copy files out of it.

But honestly, I doubt that you can do that (the ???? you've got when listing the savefile is a very very bad sign). Try to boot Windows and run chkdsk on that NTFS partition. Hopefully you're not doing this on Windows 8 boot partition - or you are in for a very nasty surprise Sad

EDIT: Please post questions related to Fatdog only in Fatdog thread. Kirk and I we don't monitor all the threads in this forum as they are mostly for Puppies; questions posted elsewhere may not get noticed and may not get a reply.

_________________
Fatdog64, Slacko and Puppeee user. Puppy user since 2.13.
Contributed Fatdog64 packages thread
Back to top
View user's profile Send private message 
Ted Dog


Joined: 13 Sep 2005
Posts: 3310
Location: Heart of Texas

PostPosted: Sat 14 Mar 2015, 16:08    Post subject:  

I have same problem with lid close, I use a few work-arounds from disabling suspend.sh (easiest to do), to adding killall X in that same script, or changing suspend type from mem to standby.
Search for my resent posts, I am actively working on understanding / fixing this issue I can't untrain decades of mindless lid close behavior Wink
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [3 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0397s ][ Queries: 11 (0.0031s) ][ GZIP on ]