(OLD) (ARCHIVED) Puppy Linux Discussion Forum Forum Index (OLD) (ARCHIVED) Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info

This forum can also be accessed as http://oldforum.puppylinux.com
It is now read-only and serves only as archives.

Please register over the NEW forum
https://forum.puppylinux.com
and continue your work there. Thank you.

 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups    
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 27 Feb 2021, 17:16
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Chrome Browser Pet Maker
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
Page 1 of 2 [20 Posts]   Goto page: 1, 2 Next
Author Message
HoerMirAuf


Joined: 22 Jan 2008
Posts: 256
Location: Würzburg

PostPosted: Thu 09 Apr 2015, 14:12    Post subject:  Chrome Browser Pet Maker  

Hi Volks,

wrote a little script to download the current stable google-chrome-i386 and convert it to a pet.

Works with slacko, should work with other puppy too.

Please note, google-chrome need Orbit !

Update 03.11.15:
Chrome2pet-2.5.pet

Will support now 64bit versions too! Also choosable to run without Sandbox.
Needed for Kernels without namespace, seccomp support.

Need Orbit2 gconf dbus.


Update 05.05.15:
Chrome2pet-2.4.pet

Update 06.05.15:
Chrome2Pet_Quirky-2.4.pet

Need now no other libs or else... also a update-installation function included

-------------------------------------------------
EDIT

Ok ... the newer google-chrome will not run with slacko. The kernel is too old an dont support SUID sandbox.

The only solution is to run it without sandbox:

Code:
google-chrome-stable --disable-setuid-sandbox


libgconf is needed now.
c2p1.png
 Description   
 Filesize   14.62 KB
 Viewed   4391 Time(s)

c2p1.png

c2p2.png
 Description   
 Filesize   9.8 KB
 Viewed   4422 Time(s)

c2p2.png


Last edited by HoerMirAuf on Tue 03 Nov 2015, 14:39; edited 20 times in total
Back to top
View user's profile Send private message 
sonny


Joined: 29 Jan 2015
Posts: 34
Location: Washington State

PostPosted: Thu 09 Apr 2015, 15:26    Post subject:  

I tried it a few time in tahrpup. The pet it makes was 0mb. It said failed to install. Not sure what the problem is...We need a guitarix pet like this that installs the latest version, that would be epic....I will continue to investigate...Thanks..

My bad, I'm missing this libbfd-2.22.52.0.2.20120424.so which is slackware... Razz
Back to top
View user's profile Send private message 
HoerMirAuf


Joined: 22 Jan 2008
Posts: 256
Location: Würzburg

PostPosted: Thu 09 Apr 2015, 20:42    Post subject:  

Hi sonny,

but this lib is included in the /usr/local/chrome2pet folder and the lib-path is set to this folder.
Have you changed this path?

(obsolete look at the first post)

chrome2pet worked on my tahr OOTB ...
Back to top
View user's profile Send private message 
sonny


Joined: 29 Jan 2015
Posts: 34
Location: Washington State

PostPosted: Fri 10 Apr 2015, 12:17    Post subject:  

I tried on a fresh install of tarhpup with devx. It did make a pet package. I got an error "google-chrome.pet is named etc inside pet file". will not install it....
Back to top
View user's profile Send private message 
HoerMirAuf


Joined: 22 Jan 2008
Posts: 256
Location: Würzburg

PostPosted: Fri 10 Apr 2015, 13:12    Post subject:  

Hmmm .... you can start the script from terminal.
only type chrome2pet an let me know the terminal output.

But ... works with slacko without any error. Also with tahr 6.0.2...
In both case a fresh install.
Which tahr are you using?

EDIT:
ok ... found some differences in dpkg-deb between slacko and tahr.
But should although work.
Added some additional functions. Now it's version 2.1

Please give me a feedback
capture25453.png
 Description   
 Filesize   136.12 KB
 Viewed   5903 Time(s)

capture25453.png

capture26501.png
 Description   
 Filesize   138.02 KB
 Viewed   5838 Time(s)

capture26501.png

capture30102.png
 Description   
 Filesize   68.6 KB
 Viewed   5871 Time(s)

capture30102.png

Back to top
View user's profile Send private message 
sonny


Joined: 29 Jan 2015
Posts: 34
Location: Washington State

PostPosted: Sat 11 Apr 2015, 14:06    Post subject:  

It works!!!!!! Thank you for your time an efforts. Very Happy

Tahrpup 6.0.2
Back to top
View user's profile Send private message 
puppynovice

Joined: 04 May 2015
Posts: 4

PostPosted: Mon 04 May 2015, 21:57    Post subject: Chrome Browser Won't Launch
Subject description: Chrome2pet-2.3.pet and Google-Chrome.pet
 

System: Dell Core 2 Duo, 4GB Ram, Puppy Quirky 7.0.4.1-32bit with Live-CD.

(Attempted similar with Quirky-64bit 7.0.4.1 and GetLatest64bitChromeVersion-V3.pet, same results)

1. Installed Chrome2pet-2.3.pet

2. Above made Chrome2pet on Utility Menu

3. Chrome2pet made Google-Chrome.pet

4. Installed Chrome with Google-Chrome.pet

5. Chrome-Stable or Incognito will NOT launch from menu, pRun, or terminal.

Any specific suggestions for above situation?
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 13981
Location: S.C. USA

PostPosted: Mon 04 May 2015, 22:32    Post subject:  

sonny wrote:
I tried on a fresh install of tarhpup with devx. It did make a pet package. I got an error "google-chrome.pet is named etc inside pet file". will not install it....

In Tahrpup 6.0.2 updated with Quickpet->info-> tahrpup update at 05/04/2015.

Using Chome2pet-2.3 I get this same message when trying to install the pet that is made.

_________________
The things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
YaPI(any iso installer)
Back to top
View user's profile Send private message 
sonny


Joined: 29 Jan 2015
Posts: 34
Location: Washington State

PostPosted: Tue 05 May 2015, 00:04    Post subject:  

ETP has a getlatestchromeversion- pet that works very well in tahrpup...

http://murga-linux.com/puppy/viewtopic.php?t=97548&start=15
Back to top
View user's profile Send private message 
puppynovice

Joined: 04 May 2015
Posts: 4

PostPosted: Tue 05 May 2015, 04:12    Post subject: Chrome Browser Won't Launch  

Thanks for responses.

System: Dell Core 2 Duo, 4GB RAM, Quirky 7.0.4.1

I've attempted below, Chrome won't start.

1. Chrome2pet-2.3.pet
2. GetLatestChromeVersion-V2.pet
3. GetLatest32bitChromeVersion-V3.pet
4. GetLatest64bitChromeVersion-V3.pet (64bit Live-CD)
5. Google Chrome .deb downloads for 32bit and 64bit,
with respective 32bit and 64bit Live-CDs.

Has anyone got Google Chrome to run on Quirky 7.0.4.1?

What is the solution?
Back to top
View user's profile Send private message 
HoerMirAuf


Joined: 22 Jan 2008
Posts: 256
Location: Würzburg

PostPosted: Tue 05 May 2015, 04:44    Post subject:  

Wich kernel is included in Quirky?

the current Google-Chrome need a kernel (higher than 3.17) compiled with namespace, seccomp, tsync support. otherwise it will not lauch because the sandbox is not working. You can try to run chrome without sandbox:


google-chrome-stable --disable-setuid-sandbox

or

google-chrome-stable --no-sandbox

have you tryed a older version from google-chrome?
http://www.murga-linux.com/puppy/viewtopic.php?t=98242
This one was running in slacko without any problems


EDIT:

ok ... was testing this. Quirky Kernel (3.17) is compiled without User PID NET namespace support. So You can only run google chrome without uid sandbox

google-chrome-stable --disable-setuid-sandbox

Also some libs was missing, like glibconf libdbus libdbus-glib
capture20197.png
 Description   
 Filesize   66.9 KB
 Viewed   5510 Time(s)

capture20197.png

capture23093 (2).png
 Description   
 Filesize   64.38 KB
 Viewed   5537 Time(s)

capture23093 (2).png

Back to top
View user's profile Send private message 
HoerMirAuf


Joined: 22 Jan 2008
Posts: 256
Location: Würzburg

PostPosted: Tue 05 May 2015, 09:13    Post subject:  

Can also confirm the "etc inside" Bug after update tahr.

But why? Why schould a pet package not contain files for the etc directory?
This should happen also with other pet's .... Shocked

Is fixed look at the first Post Chrome2Pet-2.4
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 13981
Location: S.C. USA

PostPosted: Tue 05 May 2015, 15:04    Post subject:  

What was the fix?
_________________
The things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
YaPI(any iso installer)
Back to top
View user's profile Send private message 
ETP


Joined: 19 Oct 2010
Posts: 1202
Location: UK

PostPosted: Tue 05 May 2015, 16:24    Post subject: 64 bit Chrome  

@puppynovice

Quote:
Has anyone got Google Chrome to run on Quirky 7.0.4.1?


Yes, in Rapid Pup V1 & V2 (Based on 7.0.4.1)using GetLatest64bitChromeVersion-V4.pet
https://drive.google.com/folderview?id=0B_iVVJCd9q09fnEyWV9jZHQtS0lMUG5jVnJrWDZVa295WkFMNUJEV091QXNsRFU0TVVnM3M&usp=sharing

Do not attempt to use it in anything other than Quirky 7.0.4.1 as it contains libs plus other custom stuff.

Before you attempt to use the pet all traces of any previous Chrome installs should be removed.

It does not have sandboxing & does not make a pet. First use will download & install the latest 64bit Chrome-Stable.

_________________
Regards ETP

Kennels
Back to top
View user's profile Send private message 
slavvo67

Joined: 12 Oct 2012
Posts: 1625
Location: The other Mr. 305

PostPosted: Tue 05 May 2015, 21:44    Post subject:  

This pet does not install correctly for those using PPM2. There is a glitch or coding that requires the file inside the pet to match the pet. Why? Good question. Anyway, unpacking the pet and repackaging it seems to work.

Best,

Slavvo67
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 2 [20 Posts]   Goto page: 1, 2 Next
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0532s ][ Queries: 12 (0.0066s) ][ GZIP on ]