Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 28 Jul 2016, 08:44
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
X-tahr-1b3 beta
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 11 [162 Posts]   Goto page: 1, 2, 3, ..., 9, 10, 11 Next
Author Message
rg66


Joined: 23 Jul 2012
Posts: 1042
Location: Vancouver, BC Canada / Entebbe, Uganda Africa!?!

PostPosted: Thu 18 Jun 2015, 06:28    Post subject:  X-tahr-1b3 beta
Subject description: tahr-6.0.2 with Xfce-4.12.x
 

X-tahr is based on tahrpup-6.0.2 CE with the Xfce-4.12.x desktop environment.
Beta 1bx comes with the 3.14.20 noPAE kernel and is a testing release.

Thanks go to tahr developer 666philb, smokey01 for hosting, and as usual, Geoffrey.

Download verson 1b3 ISO and delta
http://smokey01.com/rg66/X-tahr/testing/

1b2 ISO thanks to ally
http://archive.org/download/Puppy_Linux_X-tahr
md5sum 02292fe2897d668a45a22ba99bab1c69

Recommended minimum requirements
2Ghz CPU and 1GB RAM
X-tahr.jpg
 Description   
 Filesize   58.84 KB
 Viewed   4393 Time(s)

X-tahr.jpg


_________________
X-slacko-4.1 - X-tahr-1b3 - X-precise-2.4
X-series repo

Last edited by rg66 on Mon 14 Sep 2015, 18:31; edited 9 times in total
Back to top
View user's profile Send private message 
rg66


Joined: 23 Jul 2012
Posts: 1042
Location: Vancouver, BC Canada / Entebbe, Uganda Africa!?!

PostPosted: Thu 18 Jun 2015, 06:47    Post subject:  

Note:

1) Service Pack checks have been disabled as the .pet may overwrite some customized scripts. I will most likely integrate important SP bits into future releases.

2) PPM databases were updated on June 18 2015

_________________
X-slacko-4.1 - X-tahr-1b3 - X-precise-2.4
X-series repo

Last edited by rg66 on Mon 22 Jun 2015, 14:14; edited 6 times in total
Back to top
View user's profile Send private message 
Marv


Joined: 04 May 2005
Posts: 704
Location: SW Wisconsin

PostPosted: Thu 18 Jun 2015, 14:04    Post subject:  

Downloaded, md5sum checked ok. Grub4Dos frugal install (pristine) to Intel SATA SSD on core 2 duo iwlwifi Intel mobile series 4 video laptop. Sound ok on boot, video uses Intel driver and Mesa, glxgears 1350 FPS (as expected on this laptop). Wireless connection flawless using Frisbee. Posting from Firefox in it now (did make symlink in /root/.mozilla to my common Firefox profile. Singleclicked it and will make a savefile and use it. Touchpad also completely usable OOTB. Haven't turned off the tap-to-click yet, set any wallpaper or played with icons.

Edit: Savefile created correctly (unencrypted, 256Mb, EXT2), reboot fine. Lid suspend works OOTB on this laptop. More later..

Thanks,

_________________
Pups currently in kennel Very Happy X-slacko 3.1n, X-tahr 1b3 and LxPupTahr for my users; LxPupSc, LxPupXenial and X-slacko 4 for me. All good pups indeed.
Back to top
View user's profile Send private message 
rg66


Joined: 23 Jul 2012
Posts: 1042
Location: Vancouver, BC Canada / Entebbe, Uganda Africa!?!

PostPosted: Thu 18 Jun 2015, 14:39    Post subject:  

Thanks for the report Marv, I can always count on you. Good to hear about the touchpad, X-slacko always had tap-to-click disabled OOTB which I want enabled.

I edited shutdownconfig not only to get rid of as much yellow as possible but to eliminate asking for encryption if a save dir is chosen. Too many clicks to save in my opinion.

_________________
X-slacko-4.1 - X-tahr-1b3 - X-precise-2.4
X-series repo
Back to top
View user's profile Send private message 
ally


Joined: 19 May 2012
Posts: 1208
Location: lincoln, uk

PostPosted: Thu 18 Jun 2015, 14:49    Post subject:  

mirrored here: http://archive.org/details/Puppy_Linux_X-tahr

Smile
Back to top
View user's profile Send private message Visit poster's website 
starhawk

Joined: 22 Nov 2010
Posts: 4999
Location: Everybody knows this is nowhere...

PostPosted: Thu 18 Jun 2015, 15:10    Post subject:  

I've downloaded it... I'll test it myself (on the Poulsbo box for sure, possibly also on the Dell E4310 laptop) approximately when I get around to it... probably in the next two or three days.
_________________

Back to top
View user's profile Send private message 
rg66


Joined: 23 Jul 2012
Posts: 1042
Location: Vancouver, BC Canada / Entebbe, Uganda Africa!?!

PostPosted: Thu 18 Jun 2015, 16:43    Post subject:  

ally wrote:
mirrored here: http://archive.org/details/Puppy_Linux_X-tahr

Smile


Thanks ally, looks good.

_________________
X-slacko-4.1 - X-tahr-1b3 - X-precise-2.4
X-series repo
Back to top
View user's profile Send private message 
siklopz

Joined: 10 Jun 2015
Posts: 9

PostPosted: Thu 18 Jun 2015, 17:27    Post subject: thanks  

i just want to thank you for your work. x-precise was one of my favorite puplets, and i look forward to trying this one out. would you mind if i link it on the Puppy Linux Users Group on Facebook?
Back to top
View user's profile Send private message 
rg66


Joined: 23 Jul 2012
Posts: 1042
Location: Vancouver, BC Canada / Entebbe, Uganda Africa!?!

PostPosted: Thu 18 Jun 2015, 17:42    Post subject: Re: thanks  

siklopz wrote:
i just want to thank you for your work. x-precise was one of my favorite puplets, and i look forward to trying this one out.

Thanks, I appreciate it.

Quote:
would you mind if i link it on the Puppy Linux Users Group on Facebook

Not at all, just remember it's beta and probably has a lot of bugs.

_________________
X-slacko-4.1 - X-tahr-1b3 - X-precise-2.4
X-series repo
Back to top
View user's profile Send private message 
Marv


Joined: 04 May 2005
Posts: 704
Location: SW Wisconsin

PostPosted: Thu 18 Jun 2015, 21:44    Post subject:  

Continuing.. Using standard.svg icons, xfce4 v 1.0.5 battery monitor plugin installed using the PPM and added to the panel. Swapped in my retro-retro default 4.0 xfce theme, ran my browserlink pet to set up the external ones, mostly for Opera as I have been using it and the ESR Firefox with the tabs on bottom and Ghostery addons pretty much exclusively. Set up my networked HP4500 Officejet computer using a hplip 3.14.10 pet and the inbuilt CUPS. No hitches at all there with the printing. Never scan or FAX with it. Wallpaper set (came up without on the pristine install). Fiddling with governor etc. Don't have a good feel yet for CPU use etc. Seems ok, maybe a bit 'heavier' than X-slacko but I've been trimming and customizing that as it progressed so apples and oranges yet.

Several X restarts and a couple of reboots all ok too.

Anything I should try and break? Haven't managed to yet Smile

_________________
Pups currently in kennel Very Happy X-slacko 3.1n, X-tahr 1b3 and LxPupTahr for my users; LxPupSc, LxPupXenial and X-slacko 4 for me. All good pups indeed.
Back to top
View user's profile Send private message 
rg66


Joined: 23 Jul 2012
Posts: 1042
Location: Vancouver, BC Canada / Entebbe, Uganda Africa!?!

PostPosted: Thu 18 Jun 2015, 21:57    Post subject:  

Marv wrote:
Wallpaper set (came up without on the pristine install).

Initial boot had no wallpaper? Strange, it booted like that in Vbox but can't reproduce on my desktop.

Quote:
Anything I should try and break? Haven't managed to yet Smile

Not off the top of my head, it took me a week to build it so I think I got the major bugs sorted. Shocked

_________________
X-slacko-4.1 - X-tahr-1b3 - X-precise-2.4
X-series repo
Back to top
View user's profile Send private message 
Marv


Joined: 04 May 2005
Posts: 704
Location: SW Wisconsin

PostPosted: Thu 18 Jun 2015, 22:31    Post subject:  

rg66 wrote:
Marv wrote:
Wallpaper set (came up without on the pristine install).

Initial boot had no wallpaper? Strange, it booted like that in Vbox but can't reproduce on my desktop.


When I bring it up on some of the other computers I'll do pristine boots first and see if it shows up there. Seemed as though the directory 'backgrounds' wasn't selected. Pretty sure it came up blank after the savefile creation and first reboot as well. I thought backgrounds might be empty so I copied an image or two there and then selected backgrounds as the directory in the wallpaper chooser and there they all were.

_________________
Pups currently in kennel Very Happy X-slacko 3.1n, X-tahr 1b3 and LxPupTahr for my users; LxPupSc, LxPupXenial and X-slacko 4 for me. All good pups indeed.
Back to top
View user's profile Send private message 
rg66


Joined: 23 Jul 2012
Posts: 1042
Location: Vancouver, BC Canada / Entebbe, Uganda Africa!?!

PostPosted: Thu 18 Jun 2015, 22:38    Post subject:  

Marv wrote:
When I bring it up on some of the other computers I'll do pristine boots first and see if it shows up there. Seemed as though the directory 'backgrounds' wasn't selected. Pretty sure it came up blank after the savefile creation and first reboot as well. I thought backgrounds might be empty so I copied an image or two there and then selected backgrounds as the directory in the wallpaper chooser and there they all were.


It should have read the xfce4-desktop.xml to get the wallpaper, looks like it didn't but should then have defaulted to xfce-teal. I'll have to check/edit the source and recompile, must still be looking in .../backgrounds/xfce

_________________
X-slacko-4.1 - X-tahr-1b3 - X-precise-2.4
X-series repo
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 2054
Location: Queensland

PostPosted: Thu 18 Jun 2015, 23:26    Post subject:  

The wallpaper needs a symlink in /usr/share/xfce4/backdrops to /usr/share/backgrounds, that's how it is in the other xfce pups.

the /root/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-desktop.xml
is set to 4 workspaces with teal as the background.
Code:
<channel name="xfce4-desktop" version="1.0">
  <property name="backdrop" type="empty">
    <property name="screen0" type="empty">
      <property name="monitorVGA1" type="empty">
        <property name="workspace0" type="empty">
          <property name="color-style" type="int" value="0"/>
          <property name="image-style" type="int" value="5"/>
          <property name="last-image" type="string" value="/usr/share/backgrounds/xfce-blue.jpg"/>
        </property>
        <property name="workspace1" type="empty">
          <property name="color-style" type="int" value="0"/>
          <property name="image-style" type="int" value="5"/>
          <property name="last-image" type="string" value="/usr/share/backgrounds/xfce/xfce-teal.jpg"/>
        </property>
        <property name="workspace2" type="empty">
          <property name="color-style" type="int" value="0"/>
          <property name="image-style" type="int" value="5"/>
          <property name="last-image" type="string" value="/usr/share/backgrounds/xfce/xfce-teal.jpg"/>
        </property>
        <property name="workspace3" type="empty">
          <property name="color-style" type="int" value="0"/>
          <property name="image-style" type="int" value="5"/>
          <property name="last-image" type="string" value="/usr/share/backgrounds/xfce/xfce-teal.jpg"/>
        </property>
      </property>
    </property>
  </property>

_________________
Carolina: Recent Repository Additions
Create strikethrough text HERE
Back to top
View user's profile Send private message 
rg66


Joined: 23 Jul 2012
Posts: 1042
Location: Vancouver, BC Canada / Entebbe, Uganda Africa!?!

PostPosted: Thu 18 Jun 2015, 23:47    Post subject:  

Geoffrey wrote:
The wallpaper needs a symlink in /usr/share/xfce4/backdrops to /usr/share/backgrounds, that's how it is in the other xfce pups.

Xfce-4.10.x did need the symlink but 4.12 doesn't if you edit the source code right. Embarassed

Quote:
the /root/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-desktop.xml
is set to 4 workspaces with teal as the background.

Ya, not sure were that xml came from but I think part of the problem for anyone other than myself is:
Code:
<property name="monitorVGA1" type="empty">

should probably be monitor0 for most.

_________________
X-slacko-4.1 - X-tahr-1b3 - X-precise-2.4
X-series repo
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 11 [162 Posts]   Goto page: 1, 2, 3, ..., 9, 10, 11 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0617s ][ Queries: 12 (0.0042s) ][ GZIP on ]