Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 18 Dec 2014, 21:31
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Games
battle for wesnoth 1.10.sfs
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [19 Posts]   Goto page: 1, 2 Next
Author Message
666philb


Joined: 07 Feb 2010
Posts: 1943
Location: wales

PostPosted: Tue 29 Mar 2011, 23:43    Post subject:  battle for wesnoth 1.10.sfs
Subject description: superb turn-based tactical strategy game
 

The Battle for Wesnoth is a truly excellent turn-based tactical strategy game. If you haven't ever played, you really should!

Build up a great army, gradually turning raw recruits into hardened veterans. In later games, recall your toughest warriors and form a deadly host against whom none can stand! Choose units from a large pool of specialists, and hand-pick a force with the right strengths to fight well on different terrains against all manner of opposition.

Wesnoth has many different sagas waiting to be played out. Fight to regain the throne of Wesnoth, of which you are the legitimate heir... step into the boots of a young officer sent to guard a not-so-sleepy frontier outpost... lead a brutal quest to unite the orcish tribes... vanquish a horde of undead warriors unleashed by a foul necromancer, who also happens to have taken your brother hostage... guide a band of elvish survivors in an epic quest to find a new home... get revenge on the orcs by utilising the foul art or necromancy...

200+ unit types. 16 races. 6 major factions. Hundreds of years of history. The world of Wesnoth is absolutely huge and limited only by your creativity - make your own custom units, compose your own maps, and write your own scenarios or even full-blown campaigns. You can also challenge up to 8 friends - or strangers - and fight in epic multi-player fantasy battles. Loads of addons.

the battle for wesnoth can be downloaded here......
http://www.wuala.com/666philb/Documents/wesnoth-1.10_sfs4.sfs/ 322.7mb
md5 4241c9590e0532ecbce93155079921be
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

there is a Known bug with wesnoth that only affects certain versions of libsdl. It makes you unable to select anything. The solution is a different version of libsdl. The default versions in lupu520 and lupu522 are fine. However users with puppy lucid 510 will need the two libsdl libs attached at the bottom. They are from lupu520. Unzip them and put them in /usr/lib/ .It's probably a good idea to back-up the original ones first though.
enjoy
666philb aka MrFricks
libsdl_fromlupu520.tar.gz
Description  try these if you are experiencing the bug mentioned above. Click on them to unzip, and then place them in /usr/lib/
gz

 Download 
Filename  libsdl_fromlupu520.tar.gz 
Filesize  343.98 KB 
Downloaded  584 Time(s) 

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642

Last edited by 666philb on Fri 10 Oct 2014, 08:55; edited 11 times in total
Back to top
View user's profile Send private message 
erdraug

Joined: 26 Jan 2011
Posts: 10

PostPosted: Thu 31 Mar 2011, 04:27    Post subject: Re: battle for wesnoth 1.8.5.sfs
Subject description: superb turn-based tactical strategy game
 

Thank you for taking the time to build both the game and the dependencies ; i'll test asap.
Back to top
View user's profile Send private message 
GustavoYz


Joined: 07 Jul 2010
Posts: 897
Location: .ar

PostPosted: Thu 31 Mar 2011, 04:34    Post subject:  

Thanks!
It works great on LuPu 520.

_________________

Back to top
View user's profile Send private message 
Brewtal

Joined: 14 Apr 2011
Posts: 4

PostPosted: Thu 14 Apr 2011, 15:20    Post subject: Help
Subject description: How do I install or run it
 

Howdy,

I'm new to Puppy and I have just install Puppy 5.2.5 on a thumbdrive.

I have downloaded the Wesnoth SFS file and the deps.

I installed the deps with the PPM, but how do I run the game itself?

Thanks and please forgive my ignorance, I'm new to the Linux game.

Thanks,
Brewtal
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 1943
Location: wales

PostPosted: Thu 14 Apr 2011, 16:25    Post subject:  

Hi Brewtal
sfs are a special type of file.

1.Place the wesnoth.sfs file in /mnt/home/ (this is the place where puppy is installed. in your case the thumbdrive icon on the desktop.)

2. goto the menu / system / bootmanager configure bootup and press the 'choose which sfs to load at boot up'. If you've placed the sfs in the right place, you should now see it displayed. Click on it, and press the 'add' button.To make it load at bootup. Then press ok. (to uninstall use the remove button)

3.reboot

Note: in lucid puppy upto 6 sfs can be added to load at bootup. Anymore and you start to get problems. You might also find this pet useful. It allows you to load an sfs without rebooting (just right click on an sfs, and choose to load it). Unfortunately the only sfs i've found it doesn't work on though is the wesnoth.sfs above, so for that, you will have to use the traditional method above.http://shino.pos.to/linux/puppy/sfs_load-1.1.pet

let me know how you get on

666philb

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642

Last edited by 666philb on Fri 15 Apr 2011, 00:31; edited 1 time in total
Back to top
View user's profile Send private message 
Brewtal

Joined: 14 Apr 2011
Posts: 4

PostPosted: Thu 14 Apr 2011, 17:39    Post subject:  

Thanks for the reply!

I did as you said and added the SFS.

I rebooted and now I see Battle for Wesnoth and Battle for Wesnoth Map Editor in Fun.

But when I click on either of them, nothing happens...

Any ideas?

Thanks.
Brewtal
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 1943
Location: wales

PostPosted: Thu 14 Apr 2011, 17:58    Post subject:  

hi brewtal

you must have not installed all the needed deps. You said you got them from the PPM. You may have missed it, but there is a pet of all the deps in the original post above. Try installing that.

If it still doesn't work, Click the 'File/home 'icon on the desktop. then press the up arrow. then navigate to / usr / local / bin .Open a terminal there by right clicking inside the window, then choosing 'window' then 'terminal here'.

in the terminal type .....
Code:
ldd wesnoth

(that's a small L)

we're only interested in entries saying ' =>not found'
Let me know what they are

666philb

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642

Last edited by 666philb on Thu 14 Apr 2011, 18:04; edited 1 time in total
Back to top
View user's profile Send private message 
Brewtal

Joined: 14 Apr 2011
Posts: 4

PostPosted: Thu 14 Apr 2011, 18:03    Post subject:  

I loaded the deps pet before.

I ran the command you gave me and this is what I got:

./wesnoth: error while loading shared libraries: /usr/lib/libboost_iostreams.so.1.40.0: file too short
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 1943
Location: wales

PostPosted: Thu 14 Apr 2011, 18:08    Post subject:  

try reinstalling libboost iostreams here's a link
http://mirror.pnl.gov/ubuntu//pool/main/b/boost1.40/libboost-iostreams1.40.0_1.40.0-4ubuntu4_i386.deb

It would be good if you could run the
Code:
ldd wesnoth
as stated above. I will be able to get all the missing deps in one go then.

cheers

666philb

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send private message 
Brewtal

Joined: 14 Apr 2011
Posts: 4

PostPosted: Thu 14 Apr 2011, 20:43    Post subject:  

Thanks again.

I had run the; ldd wesnoth command and it gave me that error.

I reinstalled the libboost iostreams and then ran ldd wesnoth again, it gave me another error the same as the last one, but referring to another file from the deps pet. So I reload the deps pet and now I can run the game.


THANKS A MILLION!

Brewtal
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 1943
Location: wales

PostPosted: Thu 14 Apr 2011, 20:55    Post subject:  

excellent....... i think the depspet must have not installed properly for some reason.
glad it's working now

666philb

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send private message 
scabz


Joined: 30 Apr 2009
Posts: 317
Location: Tallahassee FL US

PostPosted: Thu 30 Jun 2011, 12:43    Post subject:  

hey thanks for the Wesnoth sfs, i rebuilt the sfs with the deps pet for lupu 525 included and removed the random icons located in / i am anal so the icons in that location freaked me out. here is the rebuilt sfs if anyone wants it http://www.megaupload.com/?d=N5IRBU6D
Back to top
View user's profile Send private message AIM Address Yahoo Messenger 
theinfamousj

Joined: 03 Sep 2006
Posts: 85

PostPosted: Mon 05 Sep 2011, 20:13    Post subject:  

I'm using Lupu and for some reason, Wesnoth isn't working.

My error says:
"wesnoth: error while loading shared libraries: /usr/lib/libboost_regex.so.1.40.0: file too short"

I've already tried reinstalling the deps pet, twice. Help?

Update: Apparently the third time is the charm. Anyone else with this problem ... just keep reinstalling the deps. Eventually it will work.
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 1943
Location: wales

PostPosted: Fri 03 Feb 2012, 20:59    Post subject:  

updated to 1.10 Very Happy
_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send private message 
Namm

Joined: 19 Jan 2012
Posts: 15

PostPosted: Sun 02 Dec 2012, 06:14    Post subject:  

Seems like a fun game. I have the latest Slacko. I guess I should download the current Source code version and follow the easy install guide. Oh, no, wait that guide isn't easy at all, and the overlapping dependencies and what not. God, have anyone actually managed to start the game? What's wrong with Linux? What's so evil with up-to-date ready-to-use binaries? It kills kittens? Just letting off some steam...
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 2 [19 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Games
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0824s ][ Queries: 13 (0.0057s) ][ GZIP on ]