Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 28 Jul 2014, 04:56
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Graphics
open cdr with inkscape ?
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [11 Posts]  
Author Message
andabandsen


Joined: 17 Dec 2012
Posts: 54
Location: Indonesia

PostPosted: Wed 30 Jan 2013, 04:17    Post subject:  open cdr with inkscape ?
Subject description: puppylinux 5.4.2
 

I want to open the file. cdr (coreldraw) in inkscape, said to be using unconvertor, but when I try to always fail.

http://www.sk1project.org/modules.php?name=Products&product=uniconvertor&op=download
capture26228.png
 Description   
 Filesize   13.94 KB
 Viewed   422 Time(s)

capture26228.png

Back to top
View user's profile Send private message 
Karl Godt


Joined: 20 Jun 2010
Posts: 3956
Location: Kiel,Germany

PostPosted: Mon 25 Feb 2013, 11:54    Post subject:  

Puppy and python .. l o n g .. s t o r y -- solution : compile python yourself Razz
_________________
«Give me GUI or Death» -- I give you [[Xx]term[inal]] [[Cc]on[s][ole]] .
Macpup user since 2010 on full installations.
People who want problems with Puppy boot frugal Razz
Back to top
View user's profile Send private message Visit poster's website 
Karl Godt


Joined: 20 Jun 2010
Posts: 3956
Location: Kiel,Germany

PostPosted: Mon 25 Feb 2013, 12:06    Post subject:  

Inkscapelite :

http://bkhome.org/blog/?viewDetailed=01238

_________________
«Give me GUI or Death» -- I give you [[Xx]term[inal]] [[Cc]on[s][ole]] .
Macpup user since 2010 on full installations.
People who want problems with Puppy boot frugal Razz
Back to top
View user's profile Send private message Visit poster's website 
darkcity


Joined: 23 May 2010
Posts: 2434
Location: near here

PostPosted: Mon 25 Mar 2013, 09:46    Post subject:  

I made a PET package containing Python that allows use of Inkscape's Python extensions. Should be easier than compiling yourself. Its a little old so let us know how you go. Details here-
http://murga-linux.com/puppy/viewtopic.php?t=73176

_________________
helping Wiki for help | IF SendSpace link = "dead" THEN PM me ("up file to http://meownplanet.net/")
Back to top
View user's profile Send private message Visit poster's website 
starhawk

Joined: 22 Nov 2010
Posts: 2765
Location: Everybody knows this is nowhere...

PostPosted: Wed 04 Jun 2014, 18:16    Post subject:  

Sorry to resurrect an old thread.

I'm on X-Slacko 1.1 PAE. Downloaded and installed Inkscape from PPM. Downloaded and installed the Python dotPET courtesy of darkcity in the post immediately above mine. Downloaded and installed the sk1libs and uniconvertor (but not uniconvw) packages for Ubuntu 10.04, from the sK1 Project site linked in the first post of this thread. (Why Ubuntu DEBs? Because I know they work and there weren't any Slackware *.txz packages on that site.)

Inkscape does not see UniConvertor. This makes me sad.

Can someone cheer me up by telling me how to make it work?

_________________
Loving X-Slacko 1.1! Get the PetGet patch on pg8; it's important.
Next system will be an HP MOCA-AR + Core2Duo in an innovative case... if I ever get off my butt and build it Razz
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 3578
Location: World_Hub

PostPosted: Wed 04 Jun 2014, 21:50    Post subject:  

Remove the previous lib and try this one.
Back to top
View user's profile Send private message 
starhawk

Joined: 22 Nov 2010
Posts: 2765
Location: Everybody knows this is nowhere...

PostPosted: Wed 04 Jun 2014, 22:02    Post subject:  

No joy.

Incidentally, that package has a libpython 2.7 dependency, and darkcity's package is 2.6... I wonder if that's the problem...?

_________________
Loving X-Slacko 1.1! Get the PetGet patch on pg8; it's important.
Next system will be an HP MOCA-AR + Core2Duo in an innovative case... if I ever get off my butt and build it Razz
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 3578
Location: World_Hub

PostPosted: Wed 04 Jun 2014, 22:03    Post subject:  

You should know better. If still no joy, try here.
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 1327
Location: Queensland Australia ɹǝpu∩uʍop

PostPosted: Wed 04 Jun 2014, 22:21    Post subject:  

starhawk wrote:
No joy.

Incidentally, that package has a libpython 2.7 dependency, and darkcity's package is 2.6... I wonder if that's the problem...?


Try these, works for me with Inkscape in Carolina with python 2.7

uniconvertor-1.1.5.pet

uniconvw-1.1.5.pet

sk1libs-0.9.1.pet

_________________
Carolina: Recent Repository Additions
Create strikethrough text HERE
Back to top
View user's profile Send private message 
starhawk

Joined: 22 Nov 2010
Posts: 2765
Location: Everybody knows this is nowhere...

PostPosted: Wed 04 Jun 2014, 22:33    Post subject:  

@Semme -- you're probably right, lol. Incidentally, that nluug link didn't install... but this one did --> http://distro.ibiblio.org/puppylinux/pet_packages-slacko14/python-2.7.3-i686-s.pet

Now it's telling me I need libtcl8.5.so and libtk8.5.so *sigh*

*checks to see if it's working anyways* ...and, nope. Guess I'll hunt down TCL+TK.

EDIT --

Installed TCL 8.5.6 + TK 8.5.6 from the tk-bubbles/tk-gemgame thread, still nope Sad

This is getting stupid.

BTW, Geoffrey, I'm using your dotPETs.

_________________
Loving X-Slacko 1.1! Get the PetGet patch on pg8; it's important.
Next system will be an HP MOCA-AR + Core2Duo in an innovative case... if I ever get off my butt and build it Razz
Back to top
View user's profile Send private message 
starhawk

Joined: 22 Nov 2010
Posts: 2765
Location: Everybody knows this is nowhere...

PostPosted: Wed 04 Jun 2014, 23:14    Post subject:  

ARGH.

ARGH ARGH ARGH.

I didn't have to go through all this! LibreOffice Draw opens *.cdr files JUST FINE. I didn't even know...

*head explodes*

[SOLVED] for me... by using different software.

_________________
Loving X-Slacko 1.1! Get the PetGet patch on pg8; it's important.
Next system will be an HP MOCA-AR + Core2Duo in an innovative case... if I ever get off my butt and build it Razz
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [11 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Graphics
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0662s ][ Queries: 13 (0.0071s) ][ GZIP on ]