Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 19 Jul 2018, 00:25
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
CUPS recognizes printer, installs driver but still no print
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [8 Posts]  
Author Message
Kick

Joined: 30 Apr 2016
Posts: 14

PostPosted: Wed 28 Mar 2018, 16:30    Post subject:  CUPS recognizes printer, installs driver but still no print  

Hi,

I am running a frugal installation of Puppy Precise 5.7.1 in a dual boot setup with Windows XP (the latter disconnected from the internet). I have successfully used my previous Canon Pixma IP4300 printer with Puppy on the computer and indeed with other Puppy operating systems on live discs. Unfortunately my IP4300, after years of good service, has packed up so I have replaced it with an all in one Canon Pixma TS5050 machine. This works perfectly on my Windows 7 desktop but it does not support Windows XP so, if I am to print via my older dual boot desktop, I need CUPS to run the printer in Puppy.

I have CUPS 1.4.8 and on going to http://localhost:631/, my printer is recognized and the correct TS5000 series driver is available. However, after installing the driver, when I run tests via 'Manage Printers' in http://localhost:631/ or from test documents I create on the desktop, the printer does not run. The printer is recognized by the software programs I use for the test documents and I can modify settings but the printer just does run. When I check 'Jobs' in http://localhost:631/ I see errors such as the following:
'/usr/lib/cups/filter/cmdtocanonij2 failed' and '/usr/lib/cups/filter/rastertocanonij failed'.

Although it is not a disaster if I cannot get the printer operating from Puppy Precise, it would be a bonus if I could so I welcome any suggestions from more experienced Puppy users. I seem to have got so near yet still remain so far.

Thanks and regards.
Back to top
View user's profile Send private message 
davids45


Joined: 26 Nov 2006
Posts: 1119
Location: Chatswood, NSW

PostPosted: Wed 28 Mar 2018, 17:32    Post subject: Try a link - ld-lsb.so.3 to ld-2.2x in /lib
Subject description: Needed for my Epson in many Pups
 

G'day,
In quite a few Pups, there is a missing link needed to run my Epson ink-jet multifunction which without it produces a 'filter fail' type error in CUPS.

This simple fix could be worth a check if it helps with Canon printers as well. If it doesn't, I doubt any harm will be done (but no guarantees from a non-expert like me Embarassed Wink ).

If this ld-lsb.so.3 file is already there in the /lib directory, then this is not your Canon's problem.

In /lib, there should be a file 'ld-lsb.so.3' the lack of which can be fixed by making a sym-link to the file 'ld-2.27.so' or whatever is the number between the '2.' and the '.so' - I'm in BionicPup at the moment and it has ld-2.27.so to which I have the link. But older Pups have anything from 23 to 26 here instead of 27, but they all print with my Epsons once I make the link in /lib.

Check/search through the Printers section of the Forum as well. Particularly posts by forum member rcrsn51.

David S.

(Thanks again to rcrsn51 for helping me fix this problem quite a while ago, a fix which still works for my Epson printers)
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 10710
Location: Charleston S.C. USA

PostPosted: Wed 28 Mar 2018, 19:04    Post subject:  

See if anything here helps:
http://murga-linux.com/puppy/viewtopic.php?p=644110#644110

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
Kick

Joined: 30 Apr 2016
Posts: 14

PostPosted: Thu 29 Mar 2018, 05:08    Post subject:  

Hi David and Bigpup,

Thanks for your very quick and useful replies.

Special thanks to you Bigpup as the link you gave me provided to be fruitful and I can now print from my Puppy Precise operating system on the old dual boot machine. I now have to work on my live discs but can take my time over that. I may also explore the possibility of getting the scanner part of the Canon TS5050 working from Puppy as the link provided information on that too.

Cheers and best regards to you both.
Back to top
View user's profile Send private message 
Kick

Joined: 30 Apr 2016
Posts: 14

PostPosted: Thu 12 Apr 2018, 04:48    Post subject:  

Hi,

No luck as yet getting the scanner running in Puppy but the printer itself is fine.

I have downloaded the Canon scangear driver and run the appropriate command in the terminal but, so far, no luck. However, this is not a problem for me, it was the printer I really needed to work so I am happy. The possibility of running the scanner in Puppy would be a bonus but is not essential.

Cheers.
Back to top
View user's profile Send private message 
hamoudoudou


Joined: 24 Jul 2014
Posts: 1317
Location: rabat

PostPosted: Mon 09 Jul 2018, 05:45    Post subject: imprimante canon TS 5055  

même probleme forum francophone imprimante canon TS 5055
Subject description: installation
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 12209
Location: Stratford, Ontario

PostPosted: Mon 09 Jul 2018, 06:13    Post subject: Re: imprimante canon TS 5055  

hamoudoudou wrote:
même probleme forum francophone imprimante canon TS 5055
Subject description: installation

And it's the same solution, which I have already provided - install the driver with the candi tool.

BTW, with new Canon models, the scanner program is named scangearmp2.
Back to top
View user's profile Send private message 
rockedge


Joined: 11 Apr 2012
Posts: 625
Location: Connecticut, United States

PostPosted: Mon 09 Jul 2018, 08:17    Post subject:  

rcrsn51 wrote:
BTW, with new Canon models, the scanner program is named scangearmp2.


thank you!! this info is very helpful.
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 1 [8 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0986s ][ Queries: 12 (0.0076s) ][ GZIP on ]